summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author LukenShiro2010-05-13 00:33:14 +0200
committer Robby Workman2010-05-13 00:33:14 +0200
commita3740a34e9f67565f8130557e9466cf2e5eca638 (patch)
tree47dfe6699a7a0c94379b7958298b80a5e821d60f
parent1832b4b27b2f42b9ce890276103adc9ea690aa3f (diff)
downloadslackbuilds-a3740a34e9f67565f8130557e9466cf2e5eca638.tar.gz
libraries/pytables: Updated for version 2.1.2
-rw-r--r--libraries/pytables/README3
-rw-r--r--libraries/pytables/pytables.SlackBuild20
-rw-r--r--libraries/pytables/pytables.info12
-rw-r--r--libraries/pytables/slack-desc8
4 files changed, 22 insertions, 21 deletions
diff --git a/libraries/pytables/README b/libraries/pytables/README
index b5d3203f6e..331268b08f 100644
--- a/libraries/pytables/README
+++ b/libraries/pytables/README
@@ -16,5 +16,4 @@ PyTables has been designed to fulfill the next requirements:
represented by one byte plus a small fraction when loaded
in memory.
-This requires numpy and hdf5, both of which are available from
-SlackBuilds.org.
+This requires numpy and hdf5.
diff --git a/libraries/pytables/pytables.SlackBuild b/libraries/pytables/pytables.SlackBuild
index 64e91380cf..9cd29c9301 100644
--- a/libraries/pytables/pytables.SlackBuild
+++ b/libraries/pytables/pytables.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pytables
-VERSION=${VERSION:-2.1.1}
+VERSION=${VERSION:-2.1.2}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,29 +60,27 @@ cd $SRC_PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# For now Pyrex extensions are not automatically re-built, because
-# Slackware pyrex is not yet at required version (>=0.9.8.4).
-#CFLAGS=$SLKCFLAGS \
-python setup.py build
python setup.py install --prefix=/usr --root=$PKG
-# Copy documentation, examples, contrib, and bench files
+# Copy examples, contrib, and bench files
+mkdir -p $PKG/usr/share/$PRGNAM/
+cp -a examples contrib bench $PKG/usr/share/$PRGNAM/
+
+# Copy documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cp $CWD/pytablesmanual-$VERSION.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-mkdir -p $PKG/usr/share/$PRGNAM/
-cp -a examples contrib bench $PKG/usr/share/$PRGNAM/
-
( cd $PKG
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
+ xargs strip --strip-unneeded 2> /dev/null || true
)
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pytables/pytables.info b/libraries/pytables/pytables.info
index 21c29f83d4..d336240937 100644
--- a/libraries/pytables/pytables.info
+++ b/libraries/pytables/pytables.info
@@ -1,8 +1,12 @@
PRGNAM="pytables"
-VERSION="2.1.1"
+VERSION="2.1.2"
HOMEPAGE="http://www.pytables.org/moin"
-DOWNLOAD="http://www.pytables.org/download/pytables-2.1.1/tables-2.1.1.tar.gz"
-MD5SUM="fce2100e655e91849b3d73f22274b0c4"
+DOWNLOAD="http://www.pytables.org/download/pytables-2.1.2/tables-2.1.2.tar.gz \
+ http://www.pytables.org/download/pytables-2.1.2/pytablesmanual-2.1.2.pdf"
+MD5SUM="0033be22577d76fd1689a77afb9975da \
+ 30c6512a38be9a0d52411fbe9041cb6a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"
-APPROVED="dsomero"
+APPROVED="rworkman"
diff --git a/libraries/pytables/slack-desc b/libraries/pytables/slack-desc
index cc2f1cd98c..ecf9f8542a 100644
--- a/libraries/pytables/slack-desc
+++ b/libraries/pytables/slack-desc
@@ -7,13 +7,13 @@
|-----handy-ruler----------------------------------------------------|
pytables: pytables (Hierarchical datasets in Python)
-pytables:
+pytables:
pytables: PyTables is a package for managing hierarchical datasets
pytables: and designed to efficiently and easily cope with extremely
pytables: large amounts of data. It optimizes memory and disk resources
pytables: so that data takes much less space than other solutions such
pytables: as relational or object oriented databases.
-pytables:
+pytables:
pytables: Homepage: http://www.pytables.org/moin
-pytables:
-pytables:
+pytables:
+pytables: