summaryrefslogtreecommitdiffstats
path: root/libraries/pytables/pytables.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/pytables/pytables.SlackBuild')
-rw-r--r--libraries/pytables/pytables.SlackBuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/libraries/pytables/pytables.SlackBuild b/libraries/pytables/pytables.SlackBuild
index 64e91380cf..9cd29c9301 100644
--- a/libraries/pytables/pytables.SlackBuild
+++ b/libraries/pytables/pytables.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pytables
-VERSION=${VERSION:-2.1.1}
+VERSION=${VERSION:-2.1.2}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,29 +60,27 @@ cd $SRC_PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# For now Pyrex extensions are not automatically re-built, because
-# Slackware pyrex is not yet at required version (>=0.9.8.4).
-#CFLAGS=$SLKCFLAGS \
-python setup.py build
python setup.py install --prefix=/usr --root=$PKG
-# Copy documentation, examples, contrib, and bench files
+# Copy examples, contrib, and bench files
+mkdir -p $PKG/usr/share/$PRGNAM/
+cp -a examples contrib bench $PKG/usr/share/$PRGNAM/
+
+# Copy documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cp $CWD/pytablesmanual-$VERSION.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-mkdir -p $PKG/usr/share/$PRGNAM/
-cp -a examples contrib bench $PKG/usr/share/$PRGNAM/
-
( cd $PKG
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
+ xargs strip --strip-unneeded 2> /dev/null || true
)
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}