summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/httpie/httpie.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/network/httpie/httpie.SlackBuild b/network/httpie/httpie.SlackBuild
index e3c4a04e65..78e0b1011a 100644
--- a/network/httpie/httpie.SlackBuild
+++ b/network/httpie/httpie.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=httpie
VERSION=${VERSION:-1.0.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true