summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/speedtest-cli/README2
-rw-r--r--network/speedtest-cli/speedtest-cli.SlackBuild9
-rw-r--r--network/speedtest-cli/speedtest-cli.info2
3 files changed, 10 insertions, 3 deletions
diff --git a/network/speedtest-cli/README b/network/speedtest-cli/README
index 92e211c0de..464b091550 100644
--- a/network/speedtest-cli/README
+++ b/network/speedtest-cli/README
@@ -1 +1,3 @@
Command line interface for testing internet bandwidth using speedtest.net
+
+Optional dependency: python3
diff --git a/network/speedtest-cli/speedtest-cli.SlackBuild b/network/speedtest-cli/speedtest-cli.SlackBuild
index 9562919eb8..a4c0111069 100644
--- a/network/speedtest-cli/speedtest-cli.SlackBuild
+++ b/network/speedtest-cli/speedtest-cli.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=speedtest-cli
VERSION=${VERSION:-2.1.2}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/network/speedtest-cli/speedtest-cli.info b/network/speedtest-cli/speedtest-cli.info
index 759d693ea0..2f063b47fe 100644
--- a/network/speedtest-cli/speedtest-cli.info
+++ b/network/speedtest-cli/speedtest-cli.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/5c/c8/296057f78f16721863f9edb5
MD5SUM="543d38f8939e1716641cc7c00169ca03"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3"
+REQUIRES=""
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"