summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python2-sympy/README13
-rw-r--r--python/python2-sympy/python2-sympy.SlackBuild94
-rw-r--r--python/python2-sympy/python2-sympy.info10
-rw-r--r--python/python2-sympy/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/python/python2-sympy/README b/python/python2-sympy/README
new file mode 100644
index 0000000000..814629e9b6
--- /dev/null
+++ b/python/python2-sympy/README
@@ -0,0 +1,13 @@
+SymPy is a Python library for symbolic mathematics. It aims to become a
+full-featured computer algebra system (CAS) while keeping the code as
+simple as possible in order to be comprehensible and easily extensible.
+SymPy is written entirely in Python and does require just mpmath as an
+external library.
+
+SymPy has several optional dependencies which enhance its functionality
+or make it faster. Here are some available at SlackBuilds.org: numpy,
+scipy, matplotlib, ipython and pyglet. NOTE: some of these SlackBuilds
+might be available for python3 only.
+
+Version 1.5.1 is the last one available with python2 compatibility. All
+later versions are python3 only.
diff --git a/python/python2-sympy/python2-sympy.SlackBuild b/python/python2-sympy/python2-sympy.SlackBuild
new file mode 100644
index 0000000000..ba06cf2250
--- /dev/null
+++ b/python/python2-sympy/python2-sympy.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/bash
+
+# Slackware build script for python2-sympy
+
+# Copyright 2019 Serban Udrea <s.udrea@gsi.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+# Written by Grissiom <chaos.proton@gmail.com>
+# Updated for 0.6.7 by João Felipe Santos <joao.eel@gmail.com>
+# Updated for 0.7.3 & 0.7.6 by Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Updated for 0.7.1, 0.7.5, 1.3 & 1.5.1 by Serban Udrea <S.Udrea@gsi.de>
+#
+# NOTE: Version 1.5.1 is the last one with python2 compatibility
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-sympy
+SRCNAM=sympy
+VERSION=${VERSION:-1.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr/man
+rmdir $PKG/usr/share
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS LICENSE PKG-INFO README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-sympy/python2-sympy.info b/python/python2-sympy/python2-sympy.info
new file mode 100644
index 0000000000..06f7f9dfb0
--- /dev/null
+++ b/python/python2-sympy/python2-sympy.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-sympy"
+VERSION="1.5.1"
+HOMEPAGE="https://sympy.org"
+DOWNLOAD="https://files.pythonhosted.org/packages/46/3e/fbe19f658d396d52975413cd2718fbada15de5d3fa2892e23e1aca6ffed4/sympy-1.5.1.tar.gz"
+MD5SUM="b11b310c3e1642bf66e51038cb3c0021"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-mpmath"
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
diff --git a/python/python2-sympy/slack-desc b/python/python2-sympy/slack-desc
new file mode 100644
index 0000000000..eee29ba4af
--- /dev/null
+++ b/python/python2-sympy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-sympy: python2-sympy (Python2 library for symbolic mathematics)
+python2-sympy:
+python2-sympy: SymPy aims to become a full-featured computer algebra system (CAS)
+python2-sympy: while keeping the code as simple as possible in order to be
+python2-sympy: comprehensible and easily extensible.
+python2-sympy:
+python2-sympy: This version of sympy is the last one available with python2
+python2-sympy: compatibility. All later versions are python3 only.
+python2-sympy:
+python2-sympy: Homepage: https://sympy.org
+python2-sympy: