summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/powerline-status/README2
-rw-r--r--system/powerline-status/powerline-status.SlackBuild9
2 files changed, 9 insertions, 2 deletions
diff --git a/system/powerline-status/README b/system/powerline-status/README
index bf44e92102..f2f6f0f86b 100644
--- a/system/powerline-status/README
+++ b/system/powerline-status/README
@@ -1,3 +1,5 @@
Powerline is a statusline plugin for vim, and provides statuslines
and prompts for several other applications, including zsh, bash,
tmux, IPython, Awesome, i3 and Qtile.
+
+Optional dependency: python3
diff --git a/system/powerline-status/powerline-status.SlackBuild b/system/powerline-status/powerline-status.SlackBuild
index 99103b3371..edc99f6570 100644
--- a/system/powerline-status/powerline-status.SlackBuild
+++ b/system/powerline-status/powerline-status.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for powerline-status
-# Copyright 2016-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=powerline-status
VERSION=${VERSION:-2.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true