summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2022-06-04 04:34:52 +0200
committer Willy Sudiarto Raharjo2022-06-04 05:37:15 +0200
commitf5157c6596d090be1096d2a1b343bda6147de70a (patch)
tree77a780ee11c04afb204655d456da53725e60d36f
parentf0e4c698edf20ad7241cad5f91207a94fc8a4eb2 (diff)
downloadslackbuilds-f5157c6596d090be1096d2a1b343bda6147de70a.tar.gz
python/python3-pynzb: Added (NZB file format parser)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-pynzb/README11
-rw-r--r--python/python3-pynzb/python3-pynzb.SlackBuild100
-rw-r--r--python/python3-pynzb/python3-pynzb.info10
-rw-r--r--python/python3-pynzb/slack-desc19
4 files changed, 140 insertions, 0 deletions
diff --git a/python/python3-pynzb/README b/python/python3-pynzb/README
new file mode 100644
index 0000000000..914ca3b8f9
--- /dev/null
+++ b/python/python3-pynzb/README
@@ -0,0 +1,11 @@
+NZB is an XML-based file format for retrieving posts from NNTP (Usenet)
+servers. Since NZB is XML-based, it's relatively easy to build one-off
+parsers to parse NZB files. This project is an attempt to consolidate
+those many one-off NZB parsers into one simple interface.
+
+This package includes three implementations: one based on expat,
+another based on ElementTree, and a final implementation based
+on lxml. The order in which they were listed is in order of
+compatibility. The expat version should work on all versions of Python
+> 2.0, the lxml one will work on all versions > 2.5, and lxml will
+only work if you have lxml installed.
diff --git a/python/python3-pynzb/python3-pynzb.SlackBuild b/python/python3-pynzb/python3-pynzb.SlackBuild
new file mode 100644
index 0000000000..caf721d6b9
--- /dev/null
+++ b/python/python3-pynzb/python3-pynzb.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-pynzb
+
+# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
+# Written by Lionel Young <redtricycle@gmail.com>
+# Based on http://slackbuilds.org/template.SlackBuild
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pynzb
+SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
+VERSION=${VERSION:-0.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py build || exit 1
+python3 setup.py install --root=$PKG || exit 1
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pynzb/python3-pynzb.info b/python/python3-pynzb/python3-pynzb.info
new file mode 100644
index 0000000000..3df48585f3
--- /dev/null
+++ b/python/python3-pynzb/python3-pynzb.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pynzb"
+VERSION="0.1.0"
+HOMEPAGE="https://github.com/ericflo/pynzb"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pynzb/pynzb-0.1.0.tar.gz"
+MD5SUM="63c74a36348ac28aa99732dcb8be8c59"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-pynzb/slack-desc b/python/python3-pynzb/slack-desc
new file mode 100644
index 0000000000..3f40ee7b51
--- /dev/null
+++ b/python/python3-pynzb/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pynzb: python3-pynzb (NZB file format parser)
+python3-pynzb:
+python3-pynzb: NZB is an XML-based file format for retrieving posts from NNTP
+python3-pynzb: (Usenet) servers. Since NZB is XML-based, it's relatively
+python3-pynzb: easy to build one-off parsers to parse NZB files. This project is
+python3-pynzb: an attempt to consolidate those many one-off NZB parsers into one
+python3-pynzb: simple interface.
+python3-pynzb:
+python3-pynzb: Home: https://github.com/ericflo/pynzb
+python3-pynzb:
+python3-pynzb: