summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Steven Voges2023-09-01 14:03:48 +0200
committer Willy Sudiarto Raharjo2023-09-02 13:02:26 +0200
commitd8ae15c07a2292399c9fd8ac0be3970c44acf4b2 (patch)
treea350a5ce0435dd264847064668c893c410fbb75e
parent50751b025a97e3f903307c32f691a6c1c5074616 (diff)
downloadslackbuilds-d8ae15c07a2292399c9fd8ac0be3970c44acf4b2.tar.gz
libraries/crossguid: Updated for version 20190529_ca1bf4b.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/crossguid/Makefile.crossguid33
-rw-r--r--libraries/crossguid/README5
-rw-r--r--libraries/crossguid/crossguid.SlackBuild37
-rw-r--r--libraries/crossguid/crossguid.info10
-rw-r--r--libraries/crossguid/slack-desc6
5 files changed, 34 insertions, 57 deletions
diff --git a/libraries/crossguid/Makefile.crossguid b/libraries/crossguid/Makefile.crossguid
deleted file mode 100644
index a9e10b8ee3..0000000000
--- a/libraries/crossguid/Makefile.crossguid
+++ /dev/null
@@ -1,33 +0,0 @@
-override CXXFLAGS += -std=c++11 -DGUID_LIBUUID -fPIC
-override LDFLAGS += -luuid
-MAJOR := 0
-MINOR := 0
-VERSION := $(MAJOR).$(MINOR)
-NAME = crossguid
-
-INCLUDEDIR = /usr/include
-LIBDIR = /usr/lib
-
-LINK.o = $(LINK.cc)
-
-SRC = $(wildcard *.cpp)
-OBJ = $(SRC:.cpp=.o)
-LIB = lib$(NAME).so.$(VERSION)
-
-$(LIB): guid.o
- $(CXX) $(LDFLAGS) -shared -Wl,-soname,lib$(NAME).so.$(MAJOR) $^ -o $@
-
-test: $(OBJ)
-
-install: guid.h $(LIB)
- install -dm 0755 $(DESTDIR)$(INCLUDEDIR)
- install -pm 0644 guid.h $(DESTDIR)$(INCLUDEDIR)
- install -dm 0755 $(DESTDIR)$(LIBDIR)
- install -pm 0755 $(LIB) $(DESTDIR)$(LIBDIR)
- ln -sf $(LIB) $(DESTDIR)$(LIBDIR)/lib$(NAME).so
- ln -sf $(LIB) $(DESTDIR)$(LIBDIR)/lib$(NAME).so.$(MAJOR)
-
-clean:
- $(RM) $(OBJ) $(LIB) test
-
-.PHONY: run-test install clean
diff --git a/libraries/crossguid/README b/libraries/crossguid/README
index 244e3d943e..635b56971d 100644
--- a/libraries/crossguid/README
+++ b/libraries/crossguid/README
@@ -1,3 +1,4 @@
CrossGuid is a minimal, cross platform, C++ GUID library. It uses
-the best native GUID/UUID generator on the given platform and had a
-generic class for parsing, stringifying, and comparing IDs.
+the best native GUID/UUID generator on the given platform and has a
+generic class for parsing, stringifying, and comparing IDs. The guid
+generation technique is determined by your platform.
diff --git a/libraries/crossguid/crossguid.SlackBuild b/libraries/crossguid/crossguid.SlackBuild
index 22d2ae2da7..801b3875e3 100644
--- a/libraries/crossguid/crossguid.SlackBuild
+++ b/libraries/crossguid/crossguid.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for crossguid
+# Copyright 2023 Steven Voges <Oregon, USA>
# Copyright 2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=crossguid
-VERSION=${VERSION:-20160705}
-MD5LONG=fef89a4174a7bf8cd99fa9154864ce9e8e3bf989
+VERSION=${VERSION:-20190529_ca1bf4b}
+SRCVER=${SRCVER:-ca1bf4b810e2d188d04cb6286f957008ee1b7681}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,9 +68,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$MD5LONG
-tar xvf $CWD/$PRGNAM-$MD5LONG.tar.gz
-cd $PRGNAM-$MD5LONG
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
+cd $PRGNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,17 +78,28 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-cp $CWD/Makefile.$PRGNAM Makefile
-
-CXXFLAGS="$SLKCFLAGS" \
-make
-make install DESTDIR=$PKG LIBDIR=/usr/lib${LIBDIRSUFFIX}
+#Fix compile on -current/gcc13
+sed -i '26i #include <cstdint>' src/guid.cpp
+sed -i '1i #include <cstdint>' test/TestMain.cpp
+sed -i '1i #include <cstdint>' test/Test.cpp
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/crossguid/crossguid.info b/libraries/crossguid/crossguid.info
index 4e7879811d..b89cdcb22f 100644
--- a/libraries/crossguid/crossguid.info
+++ b/libraries/crossguid/crossguid.info
@@ -1,10 +1,10 @@
PRGNAM="crossguid"
-VERSION="20160705"
+VERSION="20190529_ca1bf4b"
HOMEPAGE="https://github.com/graeme-hill/crossguid"
-DOWNLOAD="https://github.com/graeme-hill/crossguid/archive/fef89a4/crossguid-fef89a4174a7bf8cd99fa9154864ce9e8e3bf989.tar.gz"
-MD5SUM="6fde62abebeab99b8e960ae65e4aa3f3"
+DOWNLOAD="https://github.com/graeme-hill/crossguid/archive/ca1bf4b810e2d188d04cb6286f957008ee1b7681/crossguid-ca1bf4b810e2d188d04cb6286f957008ee1b7681.tar.gz"
+MD5SUM="d4a8d62f3f8d6d946be75cf5bfa92687"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/libraries/crossguid/slack-desc b/libraries/crossguid/slack-desc
index 5e971dff6f..60d70d8c52 100644
--- a/libraries/crossguid/slack-desc
+++ b/libraries/crossguid/slack-desc
@@ -9,11 +9,11 @@
crossguid: crossguid (Lightweight cross platform C++ GUID/UUID library)
crossguid:
crossguid: CrossGuid is a minimal, cross platform, C++ GUID library. It uses the
-crossguid: best native GUID/UUID generator on the given platform and had a
-crossguid: generic class for parsing, stringifying, and comparing IDs.
+crossguid: best native GUID/UUID generator on the given platform and has a
+crossguid: generic class for parsing, stringifying, and comparing IDs. The guid
+crossguid: generation technique is determined by your platform.
crossguid:
crossguid: Homepage: https://github.com/graeme-hill/crossguid
crossguid:
crossguid:
crossguid:
-crossguid: