summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2023-09-18 01:02:49 +0200
committer Willy Sudiarto Raharjo2023-09-23 06:33:49 +0200
commitcf8ce466b548a96979443e5b6f09557f6eee6b1f (patch)
treec90a720bf2f88fcfa3659d2a66d75ed8d5ef05db
parentfec03eb4402a7f0a1aea58474bfdc899a18de795 (diff)
downloadslackbuilds-cf8ce466b548a96979443e5b6f09557f6eee6b1f.tar.gz
libraries/pyacoustid: Updated for version 1.3.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/pyacoustid/README4
-rw-r--r--libraries/pyacoustid/pyacoustid.SlackBuild19
-rw-r--r--libraries/pyacoustid/pyacoustid.info6
3 files changed, 11 insertions, 18 deletions
diff --git a/libraries/pyacoustid/README b/libraries/pyacoustid/README
index 0b904f837e..97d4973372 100644
--- a/libraries/pyacoustid/README
+++ b/libraries/pyacoustid/README
@@ -3,7 +3,3 @@ high-quality, open-source acoustic fingerprinting system.
This package provides Python bindings for both the fingerprinting
algorithm library, which is written in C but portable, and the Web
service, which provides fingerprint lookups.
-
-If you want to build this for use with Python 2.x (require python2)
-pass the script PYTHON2=yes, like
- PYTHON2=yes ./pyacoustid.SlackBuild
diff --git a/libraries/pyacoustid/pyacoustid.SlackBuild b/libraries/pyacoustid/pyacoustid.SlackBuild
index 5471516fc7..465a6eced0 100644
--- a/libraries/pyacoustid/pyacoustid.SlackBuild
+++ b/libraries/pyacoustid/pyacoustid.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyacoustid
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyacoustid
-VERSION=${VERSION:-1.2.2}
+VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,14 +57,14 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
-PYTHON=python3
-[ "${PYTHON2:-no}" = "yes" ] && PYTHON=python2
-
set -e
rm -rf $PKG
@@ -79,11 +76,11 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-$PYTHON setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/pyacoustid/pyacoustid.info b/libraries/pyacoustid/pyacoustid.info
index 5d6963ed2d..d604e21253 100644
--- a/libraries/pyacoustid/pyacoustid.info
+++ b/libraries/pyacoustid/pyacoustid.info
@@ -1,8 +1,8 @@
PRGNAM="pyacoustid"
-VERSION="1.2.2"
+VERSION="1.3.0"
HOMEPAGE="https://github.com/sampsyo/pyacoustid"
-DOWNLOAD="https://files.pythonhosted.org/packages/97/e6/aeada0cc05e510d655f17a4336d5a108e4bdfa95eb7d3cc0ca5415bbe568/pyacoustid-1.2.2.tar.gz"
-MD5SUM="1ae706128e7cf2cdbc9628c2ac3da579"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pyacoustid/pyacoustid-1.3.0.tar.gz"
+MD5SUM="dd7332cd4be244e54f17609f9626e165"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="audioread chromaprint"