summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Yth - Arnaud2024-03-15 14:31:38 +0100
committer Willy Sudiarto Raharjo2024-03-15 15:24:21 +0100
commitb080bcf8d7b513f55043520c6c9126ee0a9b7cbd (patch)
treedbaf6d5d82409ab9ffacdfa4eb27b504f37f650b
parent230cacbbfc855b51f48840fd6b25216ff7fa2517 (diff)
downloadslackbuilds-b080bcf8d7b513f55043520c6c9126ee0a9b7cbd.tar.gz
python/SQLAlchemy-legacy: Added (Legacy version of SQLAlchemy).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/SQLAlchemy-legacy/README14
-rw-r--r--python/SQLAlchemy-legacy/SQLAlchemy-legacy.SlackBuild82
-rw-r--r--python/SQLAlchemy-legacy/SQLAlchemy-legacy.info10
-rw-r--r--python/SQLAlchemy-legacy/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/SQLAlchemy-legacy/README b/python/SQLAlchemy-legacy/README
new file mode 100644
index 0000000000..019b4c6ed7
--- /dev/null
+++ b/python/SQLAlchemy-legacy/README
@@ -0,0 +1,14 @@
+SQLAlchemy-legacy (The Python SQL Toolkit and Object Relational Mapper)
+
+SQLAlchemy is the Python SQL toolkit and Object Relational Mapper
+that gives application developers the full power and
+flexibility of SQL.
+
+This builds the legacy 1.4 version of SQLAlchemy, for packages which
+can't yet work with SQLAlchemy 2.
+Those of which are currently limited to buildbot.
+
+Beware that SQLAlchemy-legacy and SQLAlchemy conflicts and can't be
+installed at the same time!
+However most packages using SQLAlchemy-2 may work with SQLAlchemy-legacy
+hence this could be a proper fallback, if needed.
diff --git a/python/SQLAlchemy-legacy/SQLAlchemy-legacy.SlackBuild b/python/SQLAlchemy-legacy/SQLAlchemy-legacy.SlackBuild
new file mode 100644
index 0000000000..b385f650da
--- /dev/null
+++ b/python/SQLAlchemy-legacy/SQLAlchemy-legacy.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Slackware build script for SQLAlchemy-legacy
+
+# Copyright 2024 Yth <yth@ythogtha.org>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2008 Andrea Maccis (andrea.maccis@gmail.com)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=SQLAlchemy-legacy
+SRCNAM=SQLAlchemy
+VERSION=${VERSION:-1.4.52}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES LICENSE README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/SQLAlchemy-legacy/SQLAlchemy-legacy.info b/python/SQLAlchemy-legacy/SQLAlchemy-legacy.info
new file mode 100644
index 0000000000..749f2dca23
--- /dev/null
+++ b/python/SQLAlchemy-legacy/SQLAlchemy-legacy.info
@@ -0,0 +1,10 @@
+PRGNAM="SQLAlchemy-legacy"
+VERSION="1.4.52"
+HOMEPAGE="http://www.sqlalchemy.org"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sqlalchemy/SQLAlchemy-1.4.52.tar.gz"
+MD5SUM="84e7d5eefd0d48506369d2e748de59dd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="greenlet"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/SQLAlchemy-legacy/slack-desc b/python/SQLAlchemy-legacy/slack-desc
new file mode 100644
index 0000000000..28ae2362dd
--- /dev/null
+++ b/python/SQLAlchemy-legacy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+SQLAlchemy-legacy: SQLAlchemy-legacy (Python SQL Toolkit and Object Relational Mapper)
+SQLAlchemy-legacy:
+SQLAlchemy-legacy: SQLAlchemy is the Python SQL toolkit and Object Relational Mapper
+SQLAlchemy-legacy: that gives application developers the full power and
+SQLAlchemy-legacy: flexibility of SQL.
+SQLAlchemy-legacy:
+SQLAlchemy-legacy: Homepage: http://www.sqlalchemy.org/
+SQLAlchemy-legacy:
+SQLAlchemy-legacy:
+SQLAlchemy-legacy:
+SQLAlchemy-legacy: