summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-08-25 08:47:36 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:51:41 +0200
commitab8b0d8fa4a3f470bcdff636b8fb015aee05f751 (patch)
tree1b0ef8d3f29e0713a7e1dbd39918668e38b45b01
parentf308b784eade50b815dc9bfec44ae4c51edb4c02 (diff)
downloadslackbuilds-ab8b0d8fa4a3f470bcdff636b8fb015aee05f751.tar.gz
system/kitty: Updated for version 0.23.1.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/kitty/kitty.SlackBuild36
-rw-r--r--system/kitty/kitty.info6
2 files changed, 18 insertions, 24 deletions
diff --git a/system/kitty/kitty.SlackBuild b/system/kitty/kitty.SlackBuild
index 11ce5a5d6e..0d71c2c246 100644
--- a/system/kitty/kitty.SlackBuild
+++ b/system/kitty/kitty.SlackBuild
@@ -9,7 +9,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=kitty
-VERSION=${VERSION:-0.19.3}
+VERSION=${VERSION:-0.23.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +22,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,27 +57,24 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# The Makefile ain't a real Makefile, everything's done in setup.py. Which
-# has issues:
-# - upstream claims harfbuzz >= 1.5 is required, but 14.2's 1.2 seems to work
-# just fine.
-# - CFLAGS not supported, -O3 hardcoded. The OVERRIDE stuff works, but the
-# hardcoded -O3 comes *after* them on the gcc command line. Grr.
-# - -Werror is used when compiling launcher.c, no way to disable. This assumes
-# upstream is perfect at writing code that compiles without warnings on every
-# version of gcc we might ever happen to use, and I don't believe it.
-# So, sed surgery.
-
-sed -i \
- -e "/at_least_version('harfbuzz/s,5,2," \
- -e 's,-O3,-O2,g' \
- -e 's,-Werror , ,g' \
- setup.py
+# Note to self: don't use the Makefile, it just runs setup.py but
+# doesn't give us a way to pass options to it.
+
+# sed surgery: setup.py allows overriding the compiler flags, but
+# puts a -O3 *after* whatever we set them to. All our SLKCFLAGS
+# choices have -O2.
+
+sed -i 's,-O3,-O2,g' setup.py
# The -Wl,-s makes the linker strip the binaries.
+# --ignore-compiler-warnings is needed to turn off -Werror.
+
OVERRIDE_CPPFLAGS="$SLKCFLAGS -Wl,-s" \
OVERRIDE_CFLAGS="$SLKCFLAGS -Wl,-s" \
- python3 setup.py --libdir-name lib$LIBDIRSUFFIX --verbose linux-package
+ python3 setup.py \
+ --libdir-name lib$LIBDIRSUFFIX \
+ --verbose linux-package \
+ --ignore-compiler-warnings
mkdir -p $PKG/usr/bin $PKG/usr/share $PKG/usr/lib$LIBDIRSUFFIX
cp -a linux-package/bin/* $PKG/usr/bin
diff --git a/system/kitty/kitty.info b/system/kitty/kitty.info
index 5c9800afe6..f85230c474 100644
--- a/system/kitty/kitty.info
+++ b/system/kitty/kitty.info
@@ -1,8 +1,8 @@
PRGNAM="kitty"
-VERSION="0.19.3"
+VERSION="0.23.1"
HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
-DOWNLOAD="https://github.com/kovidgoyal/kitty/releases/download/v0.19.3/kitty-0.19.3.tar.xz"
-MD5SUM="262b677889d9b979b9ce609ec7b75186"
+DOWNLOAD="https://github.com/kovidgoyal/kitty/releases/download/v0.23.1/kitty-0.23.1.tar.xz"
+MD5SUM="15d75b35038af24dd765670830c20e93"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""