summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2021-11-25 03:20:36 +0100
committer Willy Sudiarto Raharjo2021-11-25 03:20:36 +0100
commit93a74069f675d47a4b8e9bb91f35a3c149f5cad1 (patch)
treeb86e0a156a3c53bbc5cf51bec34eac89a266069b
parente9be7a871ad0baa6a25443975be1b39560e66e92 (diff)
downloadslackbuilds-93a74069f675d47a4b8e9bb91f35a3c149f5cad1.tar.gz
python-python2-pbr: Renamed from pbr.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pbr/slack-desc19
-rw-r--r--python/python2-pbr/README (renamed from python/pbr/README)2
-rw-r--r--python/python2-pbr/python2-pbr.SlackBuild (renamed from python/pbr/pbr.SlackBuild)13
-rw-r--r--python/python2-pbr/python2-pbr.info (renamed from python/pbr/pbr.info)0
-rw-r--r--python/python2-pbr/slack-desc19
5 files changed, 28 insertions, 25 deletions
diff --git a/python/pbr/slack-desc b/python/pbr/slack-desc
deleted file mode 100644
index ead08d3dbe..0000000000
--- a/python/pbr/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pbr: pbr (managing setuptools packaging in python)
-pbr:
-pbr: A library for managing setuptools packaging in a consistent manner.
-pbr:
-pbr: pbr reads and then filters the setup.cfg data through a setup hook
-pbr: to fill in default values and provide more sensible behaviors,
-pbr: and then feeds the results in as the arguments to a call to setup.py
-pbr:
-pbr:
-pbr:
-pbr:
diff --git a/python/pbr/README b/python/python2-pbr/README
index d7971dc442..e2eab1ceae 100644
--- a/python/pbr/README
+++ b/python/python2-pbr/README
@@ -6,3 +6,5 @@ decent way to run things and if you do, you should reap the rewards,
because then it's simple and repeatable. If you want to do things
differently, cool! But you've already got the power of python at your
fingertips, so you don't really need PBR.
+
+NOTE: This package consist of python2 module only.
diff --git a/python/pbr/pbr.SlackBuild b/python/python2-pbr/python2-pbr.SlackBuild
index 02d0950df8..e4ceefc4f4 100644
--- a/python/pbr/pbr.SlackBuild
+++ b/python/python2-pbr/python2-pbr.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Slackware build script for pbr
+# Slackware build script for python2-pbr
# Copyright 2014 Bogdan Radulescu, Bucharest, Romania
# All rights reserved.
@@ -24,7 +24,8 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=pbr
+PRGNAM=python2-pbr
+SRCNAM=pbr
VERSION=${VERSION:-5.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,9 +70,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -79,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/pbr/pbr.info b/python/python2-pbr/python2-pbr.info
index 07695dad77..07695dad77 100644
--- a/python/pbr/pbr.info
+++ b/python/python2-pbr/python2-pbr.info
diff --git a/python/python2-pbr/slack-desc b/python/python2-pbr/slack-desc
new file mode 100644
index 0000000000..72f7a6823b
--- /dev/null
+++ b/python/python2-pbr/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pbr: python2-pbr (managing setuptools packaging in python)
+python2-pbr:
+python2-pbr: A library for managing setuptools packaging in a consistent manner.
+python2-pbr:
+python2-pbr: pbr reads and then filters the setup.cfg data through a setup hook
+python2-pbr: to fill in default values and provide more sensible behaviors,
+python2-pbr: and then feeds the results in as the arguments to a call to setup.py
+python2-pbr:
+python2-pbr:
+python2-pbr:
+python2-pbr: