summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Markus Reichelt2023-05-26 23:21:02 +0200
committer Willy Sudiarto Raharjo2023-05-27 03:08:58 +0200
commit92b4128695fee98de443e6d8e09e45d1ca9a10a4 (patch)
treebca448c5112d0352a48d07d7c1fdc3d410783733
parent41b90f2cfa2029034f8ae773f60a4c5fe1df6945 (diff)
downloadslackbuilds-92b4128695fee98de443e6d8e09e45d1ca9a10a4.tar.gz
python/stem: Updated for version 1.8.1.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/stem/README5
-rw-r--r--python/stem/slack-desc4
-rw-r--r--python/stem/stem.SlackBuild38
-rw-r--r--python/stem/stem.info6
4 files changed, 18 insertions, 35 deletions
diff --git a/python/stem/README b/python/stem/README
index 7156686e08..f896f4abbb 100644
--- a/python/stem/README
+++ b/python/stem/README
@@ -1,9 +1,10 @@
stem is a Python controller library for Tor
stem is compatible with python 2.6+ (including python 3)
+Please note that stem by now is defacto unmaintained.
Having Tor installed is not required for building.
The Tor installation does not have to be from SBo.
-A python 3 module will be compiled if python 3 is installed on
-the system during compile time.
+A python 3 module will be compiled.
+In case you need a python 2 module, adapt the script.
diff --git a/python/stem/slack-desc b/python/stem/slack-desc
index 1fc24e1f8b..c38e452c08 100644
--- a/python/stem/slack-desc
+++ b/python/stem/slack-desc
@@ -9,11 +9,11 @@
stem: stem (Python controller library for Tor)
stem:
stem: This module is a Python controller library for Tor, and compatible
-stem: with python 2.6+ (including python 3)
+stem: with python 2.6+ (including python 3). Please note that stem by now
+stem: is defacto unmaintained.
stem:
stem: Homepage: https://stem.torproject.org/
stem:
stem:
stem:
stem:
-stem:
diff --git a/python/stem/stem.SlackBuild b/python/stem/stem.SlackBuild
index 62d5a10e60..1306d0845b 100644
--- a/python/stem/stem.SlackBuild
+++ b/python/stem/stem.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for stem
-# Copyright 2013-2020 Markus Reichelt, Aachen, DE
+# Copyright 2013-2023 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +23,12 @@
#
# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+# 20230526 bkw: very slightly modified by SlackBuilds.org.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=stem
-VERSION=${VERSION:-1.8.0}
+VERSION=${VERSION:-1.8.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,19 +50,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
+# 20230526 bkw: no flags (no native code) and no libdir (python does
+# it on its own)
set -e
@@ -76,23 +64,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
cd $TMP/$PRGNAM-$VERSION
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+find $PKG/usr/doc/$PRGNAM-$VERSION/ -type f -exec chmod 644 {} +
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/stem/stem.info b/python/stem/stem.info
index d43efb0881..d906ae9df5 100644
--- a/python/stem/stem.info
+++ b/python/stem/stem.info
@@ -1,8 +1,8 @@
PRGNAM="stem"
-VERSION="1.8.0"
+VERSION="1.8.1"
HOMEPAGE="https://stem.torproject.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/71/bd/ab05ffcbfe74dca704e860312e00c53ef690b1ddcb23be7a4d9ea4f40260/stem-1.8.0.tar.gz"
-MD5SUM="d60a6df201148885f62afc5e3062e92a"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/s/stem/stem-1.8.1.tar.gz"
+MD5SUM="62370880ad59ffa00e46618bd58b3527"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""