summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author William PC2022-11-05 03:06:14 +0100
committer Willy Sudiarto Raharjo2022-11-05 15:15:08 +0100
commit8e825e51c3c5c606df8b1fcf724d62ae1f0d2d73 (patch)
tree3600bf9b598193600cfdf2005f3765b4a9221058
parent5c3cdd429e49652f4b44ce7141ceb56a008f75e8 (diff)
downloadslackbuilds-8e825e51c3c5c606df8b1fcf724d62ae1f0d2d73.tar.gz
development/berkeley-abc: Added (binary sequential logic circuit)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/berkeley-abc/README13
-rw-r--r--development/berkeley-abc/berkeley-abc.SlackBuild124
-rw-r--r--development/berkeley-abc/berkeley-abc.info10
-rw-r--r--development/berkeley-abc/slack-desc19
4 files changed, 166 insertions, 0 deletions
diff --git a/development/berkeley-abc/README b/development/berkeley-abc/README
new file mode 100644
index 0000000000..2b4f1bc91f
--- /dev/null
+++ b/development/berkeley-abc/README
@@ -0,0 +1,13 @@
+ ABC is a growing software system for synthesis and verification of
+binary sequential logic circuits appearing in synchronous hardware
+designs. ABC combines scalable logic optimization based on
+And-Inverter Graphs (AIGs), optimal-delay DAG-based technology
+mapping for look-up tables and standard cells, and innovative
+algorithms for sequential synthesis and verification.
+
+ ABC provides an experimental implementation of these algorithms
+and a programming environment for building similar applications.
+Future development will focus on improving the algorithms and making
+most of the packages stand-alone. This will allow the user to
+customize ABC for their needs as if it were a tool-box rather than
+a complete tool.
diff --git a/development/berkeley-abc/berkeley-abc.SlackBuild b/development/berkeley-abc/berkeley-abc.SlackBuild
new file mode 100644
index 0000000000..7e30765d1f
--- /dev/null
+++ b/development/berkeley-abc/berkeley-abc.SlackBuild
@@ -0,0 +1,124 @@
+#!/bin/bash
+
+# Slackware build script for berkley-abc
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=berkeley-abc
+VERSION=${VERSION:-20221019}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+COMMIT=70cb339f869e485802159d7f2b886130793556c4
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf abc-$COMMIT
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd abc-$COMMIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make abc libabc.so
+
+# install
+mkdir -p $PKG/usr/{bin,lib${LIBDIRSUFFIX}}
+cp -av abc $PKG/usr/bin
+cp -av libabc.so $PKG/usr/lib${LIBDIRSUFFIX}
+
+# install examples
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -av src/demo.c i10.aig $PKG/usr/share/$PRGNAM-$VERSION
+
+cat >> $PKG/usr/share/$PRGNAM-$VERSION/Makefile <<EOF
+LDLIBS = -labc -lm -ldl -lreadline -lpthread
+
+all: demo.c
+ gcc -Wall -g -c $< -o demo.o
+ g++ -g -o demo demo.o \$(LDLIBS)
+EOF
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ copyright.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/berkeley-abc/berkeley-abc.info b/development/berkeley-abc/berkeley-abc.info
new file mode 100644
index 0000000000..e0984d61f7
--- /dev/null
+++ b/development/berkeley-abc/berkeley-abc.info
@@ -0,0 +1,10 @@
+PRGNAM="berkeley-abc"
+VERSION="20221019"
+HOMEPAGE="https://people.eecs.berkeley.edu/~alanmi/abc"
+DOWNLOAD="https://github.com/berkeley-abc/abc/archive/70cb339f869e485802159d7f2b886130793556c4/berkeley-abc-20221019.tar.gz"
+MD5SUM="b68f658e12c37989fa1068ba12770878"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/development/berkeley-abc/slack-desc b/development/berkeley-abc/slack-desc
new file mode 100644
index 0000000000..c6140ac28a
--- /dev/null
+++ b/development/berkeley-abc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+berkeley-abc: berkeley-abc (Synthesis&Verification binary sequential logic circuit)
+berkeley-abc:
+berkeley-abc:
+berkeley-abc: ABC is a growing software system for synthesis and verification of
+berkeley-abc: binary sequential logic circuits appearing in synchronous hardware
+berkeley-abc: designs. ABC combines scalable logic optimization based on
+berkeley-abc: And-Inverter Graphs (AIGs), optimal-delay DAG-based technology
+berkeley-abc: mapping for look-up tables and standard cells, and innovative
+berkeley-abc: algorithms for sequential synthesis and verification.
+berkeley-abc:
+berkeley-abc: