summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author newHeiko2021-02-19 16:12:17 +0100
committer Robby Workman2021-04-18 06:19:28 +0200
commit73fc67c82c77e63bc4539dd2f7419d85f2f1c281 (patch)
tree661fd88fd7dfaf1b632d9dcbde10f443e5557e02
parentf706b0bc334afad2709a0e056d4d01b20aca3276 (diff)
downloadslackbuilds-73fc67c82c77e63bc4539dd2f7419d85f2f1c281.tar.gz
python/dulwich: Add python3 support.
dulwich is a dependency of hg-git, a mercurial plugin: mercurial is python3-only in current, so its plugins need python3 support. Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/dulwich/dulwich.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/dulwich/dulwich.SlackBuild b/python/dulwich/dulwich.SlackBuild
index 714e5bf381..4c07ddc556 100644
--- a/python/dulwich/dulwich.SlackBuild
+++ b/python/dulwich/dulwich.SlackBuild
@@ -57,6 +57,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true