summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2022-01-11 19:11:17 +0100
committer Willy Sudiarto Raharjo2022-01-17 03:03:30 +0100
commit6ee2255a866387b2084b0e2716ec14bea4d60ca7 (patch)
treea60c0b48d746381225ff0f61dae4bc3d3f66a629
parentfb021c585530b602ae8d6c8f37c582848ae751fc (diff)
downloadslackbuilds-6ee2255a866387b2084b0e2716ec14bea4d60ca7.tar.gz
desktop/xpra: Added (remote X11 desktop proxy)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/xpra/README9
-rw-r--r--desktop/xpra/doinst.sh13
-rw-r--r--desktop/xpra/mkdoc.sh39
-rw-r--r--desktop/xpra/slack-desc19
-rw-r--r--desktop/xpra/xpra.SlackBuild94
-rw-r--r--desktop/xpra/xpra.info12
6 files changed, 186 insertions, 0 deletions
diff --git a/desktop/xpra/README b/desktop/xpra/README
new file mode 100644
index 0000000000..b8af2867a8
--- /dev/null
+++ b/desktop/xpra/README
@@ -0,0 +1,9 @@
+xpra (remote X11 desktop proxy)
+
+Xpra is known as "screen for X". Its seamless mode allows you to
+run X11 programs, usually on a remote host, direct their display
+to your local machine, and then to disconnect from these programs
+and reconnect from the same or another machine(s), without losing
+any state. This effectively gives you remote access to individual
+graphical applications. It can also be used to access existing
+desktop sessions and start remote desktop sessions.
diff --git a/desktop/xpra/doinst.sh b/desktop/xpra/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/desktop/xpra/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/xpra/mkdoc.sh b/desktop/xpra/mkdoc.sh
new file mode 100644
index 0000000000..b5324851fa
--- /dev/null
+++ b/desktop/xpra/mkdoc.sh
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+# Create the xpra-prebuilt-docs tarball. Part of SlackBuilds.org xpra
+# build. Run from within the SlackBuild dir. Does not require root
+# acces, but does need to write to its current directory.
+
+set -e
+
+# get VERSION:
+source ./xpra.info
+
+OUTDIR=xpra-$VERSION-prebuilt-docs
+TARBALL=$OUTDIR.tar.xz
+
+RPMFILE=xpra-common-4.3-10.el8.noarch.rpm
+URL=https://www.xpra.org/dists/CentOS/8/x86_64/$RPMFILE
+
+# only download the file if we don't already have it.
+[ -e $RPMFILE ] || wget $URL
+[ -e $RPMFILE ] || exit 1
+
+rm -rf $OUTDIR
+mkdir -p $OUTDIR
+cd $OUTDIR
+
+# extract without creating an intermediate tarball (as rpm2targz would):
+rpm2cpio ../$RPMFILE | cpio -imd
+
+# remove everything but the docs:
+mkdir .keep
+mv usr/share/doc/xpra/* .keep
+rm -rf *
+mv .keep/* .
+rmdir .keep
+
+# now ready to create the tarball.
+cd -
+tar cvfJ $TARBALL $OUTDIR
+md5sum $TARBALL
diff --git a/desktop/xpra/slack-desc b/desktop/xpra/slack-desc
new file mode 100644
index 0000000000..6b5e72d999
--- /dev/null
+++ b/desktop/xpra/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xpra: xpra (remote X11 desktop proxy)
+xpra:
+xpra: Xpra is known as "screen for X". Its seamless mode allows you to
+xpra: run X11 programs, usually on a remote host, direct their display
+xpra: to your local machine, and then to disconnect from these programs
+xpra: and reconnect from the same or another machine(s), without losing
+xpra: any state. This effectively gives you remote access to individual
+xpra: graphical applications. It can also be used to access existing
+xpra: desktop sessions and start remote desktop sessions.
+xpra:
+xpra:
diff --git a/desktop/xpra/xpra.SlackBuild b/desktop/xpra/xpra.SlackBuild
new file mode 100644
index 0000000000..c8af20edda
--- /dev/null
+++ b/desktop/xpra/xpra.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/bash
+
+# Slackware build script for xpra
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=xpra
+VERSION=${VERSION:-4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# no SLKCFLAGS because I don't see how to force setup.py to use it.
+# no LIBDIRSUFFIX needed.
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION-prebuilt-docs.tar.xz
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+sed -i 's,"share/man","man",' setup.py
+
+# without-strict turns off -Werror. without-docs because we don't want
+# pandoc *and its 139 deps* as a dependency. Include prebuilt docs
+# instead.
+python3 setup.py install \
+ --root=$PKG \
+ --without-docs \
+ --without-strict \
+ --without-debug
+
+# This is *much* faster than using 'file' to classify them.
+find $PKG/usr/lib* -name '*.so' | xargs strip --strip-unneeded
+
+gzip -9 $PKG/usr/man/man?/*
+
+# put the icons in the right places.
+cd $PKG/usr/share/icons
+ for i in *.png; do
+ px="$( identify $i | cut -d' ' -f3 )"
+ mkdir -p hicolor/$px/apps
+ mv $i hicolor/$px/apps
+ done
+cd -
+
+mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/64x64/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC/html
+
+# Instead of requiring pandoc's insanely long chain of deps, use
+# prebuilt docs. See mkdoc.sh for details.
+cp -a $PRGNAM-$VERSION-prebuilt-docs/* $PKGDOC/html
+
+cp -a COPYING README.md $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/xpra/xpra.info b/desktop/xpra/xpra.info
new file mode 100644
index 0000000000..e4ffa4e316
--- /dev/null
+++ b/desktop/xpra/xpra.info
@@ -0,0 +1,12 @@
+PRGNAM="xpra"
+VERSION="4.3"
+HOMEPAGE="https://www.xpra.org/"
+DOWNLOAD="https://github.com/Xpra-org/xpra/archive/v4.3/xpra-4.3.tar.gz \
+ https://slackware.uk/~urchlay/src/xpra-4.3-prebuilt-docs.tar.xz"
+MD5SUM="ef0ce6127936088ee2df6e49c4b3d116 \
+ bd0f11b58bc4f02d798af1568b78bb1b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"