summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author William PC2022-11-12 04:49:57 +0100
committer Willy Sudiarto Raharjo2022-11-12 04:49:57 +0100
commit6888a39bbc641cf96545a8fc39c07eb802ce08c9 (patch)
treea29aa94d019ff8bc9c3fa74d16bc8ff55a325d22
parent3f50fb224559923f9336365a90dc640e7155eff6 (diff)
downloadslackbuilds-6888a39bbc641cf96545a8fc39c07eb802ce08c9.tar.gz
academic/penaltymodel: Added (penalty model solver).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--academic/penaltymodel/README14
-rw-r--r--academic/penaltymodel/penaltymodel.SlackBuild117
-rw-r--r--academic/penaltymodel/penaltymodel.info10
-rw-r--r--academic/penaltymodel/slack-desc19
4 files changed, 160 insertions, 0 deletions
diff --git a/academic/penaltymodel/README b/academic/penaltymodel/README
new file mode 100644
index 0000000000..be84eea915
--- /dev/null
+++ b/academic/penaltymodel/README
@@ -0,0 +1,14 @@
+ One approach to solve a constraint satisfaction problem (CSP) using
+an Ising model or a QUBO, is to map each individual constraint in
+the CSP to a "small" Ising model or QUBO. This mapping is called
+a penalty model.
+
+ Imagine that we want to map an AND clause to a QUBO. In other words,
+we want the solutions to the QUBO (the solutions that minimize the
+energy) to be exactly the valid configurations of an AND gate. Let z =
+AND(x_1, x_2).
+
+
+ Optional building mode set with environment variables:
+ - TESTS=yes, performs tests. Requires: dimod, python3-numpy,
+ networkx, python3-scipy, homebase, lapack.
diff --git a/academic/penaltymodel/penaltymodel.SlackBuild b/academic/penaltymodel/penaltymodel.SlackBuild
new file mode 100644
index 0000000000..c29dee1453
--- /dev/null
+++ b/academic/penaltymodel/penaltymodel.SlackBuild
@@ -0,0 +1,117 @@
+#!/bin/bash
+
+# Slackware build script for penaltymodel
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM="penaltymodel"
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+python3 setup.py install --root=$PKG
+
+if [ "${TESTS:-no}" == "yes" ]; then
+ cd tests
+ for file in $(ls test_*.py); do
+ echo -n "$file "
+ PYTHONPATH=../ python3 $file
+ if [ "$?" -eq "0" ]; then
+ echo "OK"
+ else
+ echo "fail"
+ fi
+ done
+ cd ..
+fi
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/penaltymodel/penaltymodel.info b/academic/penaltymodel/penaltymodel.info
new file mode 100644
index 0000000000..c04f042084
--- /dev/null
+++ b/academic/penaltymodel/penaltymodel.info
@@ -0,0 +1,10 @@
+PRGNAM="penaltymodel"
+VERSION="1.0.2"
+HOMEPAGE="https://github.com/dwavesystems"
+DOWNLOAD="https://github.com/dwavesystems/penaltymodel/archive/1.0.2/penaltymodel-1.0.2.tar.gz"
+MD5SUM="26c6d33ac5a17620c4d6de76985cc552"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/academic/penaltymodel/slack-desc b/academic/penaltymodel/slack-desc
new file mode 100644
index 0000000000..1e20efbea8
--- /dev/null
+++ b/academic/penaltymodel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+penaltymodel: penaltymodel (penalty model solver for Ising model or a QUBO)
+penaltymodel:
+penaltymodel:
+penaltymodel:
+penaltymodel: One approach to solve a constraint satisfaction problem (CSP) using
+penaltymodel: an Ising model or a QUBO, is to map each individual constraint in
+penaltymodel: the CSP to a "small" Ising model or QUBO. This mapping is called
+penaltymodel: a penalty model.
+penaltymodel:
+penaltymodel:
+penaltymodel: