summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2021-08-24 19:35:54 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:51:38 +0200
commit622077d3e77c0bc1f248f17bbb16b54fa6935afc (patch)
tree510de3200b180e2e30cb54742e40e910396bf154
parent9e5f047bccf89234d5b5d5fcfd20b435c2fbdab5 (diff)
downloadslackbuilds-622077d3e77c0bc1f248f17bbb16b54fa6935afc.tar.gz
system/partimage: Fix -current build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/partimage/compilefix.diff50
-rw-r--r--system/partimage/partimage.SlackBuild17
-rw-r--r--system/partimage/partimage.info4
3 files changed, 56 insertions, 15 deletions
diff --git a/system/partimage/compilefix.diff b/system/partimage/compilefix.diff
index 4c84442046..97871ca870 100644
--- a/system/partimage/compilefix.diff
+++ b/system/partimage/compilefix.diff
@@ -1,6 +1,18 @@
+diff -Naur partimage-0.6.9/configure.ac partimage-0.6.9.patched/configure.ac
+--- partimage-0.6.9/configure.ac 2010-07-25 11:30:52.000000000 -0400
++++ partimage-0.6.9.patched/configure.ac 2021-08-24 12:54:23.661280303 -0400
+@@ -240,7 +240,7 @@
+ AC_CHECKING([ for SSL Library and Header files ... ])
+ AC_SEARCH_HEADERS(rsa.h crypto.h x509.h pem.h ssl.h err.h,
+ $SSL_HDR_DIR /usr/include/ssl /usr/include/openssl /usr/include,
+- [ AC_CHECK_LIB(crypto, CRYPTO_lock, [LIBS="$LIBS -lcrypto"],
++ [ AC_CHECK_LIB(crypto, X509_new, [LIBS="$LIBS -lcrypto"],
+ AC_MSG_ERROR([ Required for SSL Crypto Library not found. ])
+ )
+ AC_CHECK_LIB(ssl, SSL_CTX_new,
diff -Naur partimage-0.6.9/src/client/imagefile.cpp partimage-0.6.9.patched/src/client/imagefile.cpp
--- partimage-0.6.9/src/client/imagefile.cpp 2010-07-25 11:30:31.000000000 -0400
-+++ partimage-0.6.9.patched/src/client/imagefile.cpp 2016-10-21 13:28:03.035049317 -0400
++++ partimage-0.6.9.patched/src/client/imagefile.cpp 2021-08-24 12:54:00.205282436 -0400
@@ -783,7 +783,7 @@
else if (m_options.dwCompression == COMPRESS_GZIP) // Gzip compression
{
@@ -21,7 +33,7 @@ diff -Naur partimage-0.6.9/src/client/imagefile.cpp partimage-0.6.9.patched/src/
else
diff -Naur partimage-0.6.9/src/client/imagefile.h partimage-0.6.9.patched/src/client/imagefile.h
--- partimage-0.6.9/src/client/imagefile.h 2010-07-25 11:30:31.000000000 -0400
-+++ partimage-0.6.9.patched/src/client/imagefile.h 2016-10-21 13:28:03.036049317 -0400
++++ partimage-0.6.9.patched/src/client/imagefile.h 2021-08-24 12:54:00.205282436 -0400
@@ -41,7 +41,7 @@
COptions m_options;
@@ -33,7 +45,7 @@ diff -Naur partimage-0.6.9/src/client/imagefile.h partimage-0.6.9.patched/src/cl
int m_nFdImage;
diff -Naur partimage-0.6.9/src/client/misc.h partimage-0.6.9.patched/src/client/misc.h
--- partimage-0.6.9/src/client/misc.h 2010-07-25 11:30:31.000000000 -0400
-+++ partimage-0.6.9.patched/src/client/misc.h 2016-10-21 13:28:09.708049742 -0400
++++ partimage-0.6.9.patched/src/client/misc.h 2021-08-24 12:54:00.206282435 -0400
@@ -36,7 +36,7 @@
#endif
@@ -43,3 +55,35 @@ diff -Naur partimage-0.6.9/src/client/misc.h partimage-0.6.9.patched/src/client/
#endif
// =======================================================
+diff -Naur partimage-0.6.9/src/client/netclient.cpp partimage-0.6.9.patched/src/client/netclient.cpp
+--- partimage-0.6.9/src/client/netclient.cpp 2010-07-25 11:30:31.000000000 -0400
++++ partimage-0.6.9.patched/src/client/netclient.cpp 2021-08-24 12:54:23.662280303 -0400
+@@ -43,7 +43,11 @@
+ {
+ showDebug(3, "initializing client ssl\n");
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv2_client_method();
++#if OPENSSL_VERSION_NUMBER < 0x10100000
++ meth = TLSv1_client_method();
++#else
++ meth = TLS_client_method();
++#endif
+ SSL_load_error_strings();
+ ctx = SSL_CTX_new(meth);
+ if (!ctx)
+diff -Naur partimage-0.6.9/src/server/netserver.cpp partimage-0.6.9.patched/src/server/netserver.cpp
+--- partimage-0.6.9/src/server/netserver.cpp 2010-07-25 11:30:31.000000000 -0400
++++ partimage-0.6.9.patched/src/server/netserver.cpp 2021-08-24 12:54:23.662280303 -0400
+@@ -39,7 +39,11 @@
+ {
+ SSL_load_error_strings();
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv23_server_method();
++#if OPENSSL_VERSION_NUMBER < 0x10100000
++ meth = TLSv1_server_method();
++#else
++ meth = TLS_server_method();
++#endif
+ ctx = SSL_CTX_new(meth);
+ if (!ctx)
+ {
diff --git a/system/partimage/partimage.SlackBuild b/system/partimage/partimage.SlackBuild
index 1b86a053ed..4c75682a26 100644
--- a/system/partimage/partimage.SlackBuild
+++ b/system/partimage/partimage.SlackBuild
@@ -6,6 +6,8 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20210824 bkw: fix build on -current
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=partimage
@@ -22,9 +24,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -57,17 +56,15 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# apply patches from Gentoo ebuild:
# https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-block/partimage/files
-# my patch is made from their zlib-1.2.5.2 and minor-typo, rolled up into
-# one patch that will apply with -p1.
+# my patch is made from their zlib, minor-typo, and openssl patches,
+# rolled up into one patch that will apply with -p1.
patch -p1 < $CWD/compilefix.diff
+autoreconf -if
# man pages and partimaged-passwd script came from Debian:
# http://http.debian.net/debian/pool/main/p/partimage/partimage_0.6.9-3.debian.tar.xz
diff --git a/system/partimage/partimage.info b/system/partimage/partimage.info
index db4c7fddbb..f2ec2e35c5 100644
--- a/system/partimage/partimage.info
+++ b/system/partimage/partimage.info
@@ -1,7 +1,7 @@
PRGNAM="partimage"
VERSION="0.6.9"
-HOMEPAGE="http://www.partimage.org/Main_Page"
-DOWNLOAD="http://downloads.sourceforge.net/project/partimage/stable/0.6.9/partimage-0.6.9.tar.bz2"
+HOMEPAGE="https://www.partimage.org/Main_Page"
+DOWNLOAD="https://downloads.sourceforge.net/project/partimage/stable/0.6.9/partimage-0.6.9.tar.bz2"
MD5SUM="1bc046fd915c5debbafc85729464e513"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""