summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Prof. HORSTMANN2020-05-16 00:14:06 +0200
committer Willy Sudiarto Raharjo2020-05-16 03:44:12 +0200
commit5da8c8e1d68813dd1412ca6b8b6b079aa65d6ce3 (patch)
tree85702797154901d5c3746ec9fda81a3077b001ba
parent2009e730ad83db348c5cf64ba5c1cf3f0b334f60 (diff)
downloadslackbuilds-5da8c8e1d68813dd1412ca6b8b6b079aa65d6ce3.tar.gz
python/typing-extensions: Added (Backported/Experimental Type Hints)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/typing-extensions/README20
-rw-r--r--python/typing-extensions/slack-desc19
-rw-r--r--python/typing-extensions/typing-extensions.SlackBuild78
-rw-r--r--python/typing-extensions/typing-extensions.info10
4 files changed, 127 insertions, 0 deletions
diff --git a/python/typing-extensions/README b/python/typing-extensions/README
new file mode 100644
index 0000000000..a80a248d6d
--- /dev/null
+++ b/python/typing-extensions/README
@@ -0,0 +1,20 @@
+Typing Extensions – Backported and Experimental Type Hints for Python
+
+The typing module was added to the standard library in Python 3.5 on a
+provisional basis and will no longer be provisional in Python 3.7. However,
+this means users of Python 3.5 - 3.6 who are unable to upgrade will not be able
+to take advantage of new types added to the typing module, such as typing.Text
+or typing.Coroutine.
+
+The typing_extensions module contains both backports of these changes as well
+as experimental types that will eventually be added to the typing module, such
+as Protocol or TypedDict.
+
+Users of other Python versions should continue to install and use the typing
+module from PyPi instead of using this one unless specifically writing code
+that must be compatible with multiple Python versions or requires experimental
+types.
+
+Optional:
+
+python3
diff --git a/python/typing-extensions/slack-desc b/python/typing-extensions/slack-desc
new file mode 100644
index 0000000000..1f497e6ac3
--- /dev/null
+++ b/python/typing-extensions/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+typing-extensions: typing-extensions (Backported and Experimental Type Hints for Python)
+typing-extensions:
+typing-extensions: The typing module was added to the standard library in Python 3.5 on
+typing-extensions: a provisional basis and will no longer be provisional in Python 3.7.
+typing-extensions: However, this means users of Python 3.5 - 3.6 who are unable to
+typing-extensions: upgrade willnot be able to take advantage of new types added to the
+typing-extensions: typing module, such as typing.Text or typing.Coroutine.
+typing-extensions:
+typing-extensions:
+typing-extensions: Homepage: https://pypi.org/project/typing-extensions/
+typing-extensions:
diff --git a/python/typing-extensions/typing-extensions.SlackBuild b/python/typing-extensions/typing-extensions.SlackBuild
new file mode 100644
index 0000000000..b7ca9ca089
--- /dev/null
+++ b/python/typing-extensions/typing-extensions.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# SlackBuild build script for typing-extensions
+
+# Copyright (c) 2000-2020 Prof. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=typing-extensions
+PKGNAM=typing_extensions
+VERSION=${VERSION:-3.7.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PKGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+ # Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+fi
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PKGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/typing-extensions/typing-extensions.info b/python/typing-extensions/typing-extensions.info
new file mode 100644
index 0000000000..d4fe1b83c5
--- /dev/null
+++ b/python/typing-extensions/typing-extensions.info
@@ -0,0 +1,10 @@
+PRGNAM="typing-extensions"
+VERSION="3.7.4.2"
+HOMEPAGE="https://pypi.org/project/typing-extensions/"
+DOWNLOAD="https://files.pythonhosted.org/packages/6a/28/d32852f2af6b5ead85d396249d5bdf450833f3a69896d76eb480d9c5e406/typing_extensions-3.7.4.2.tar.gz"
+MD5SUM="f2674282966dc088d10170c2347431cc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Prof. HORSTMANN"
+EMAIL="wmh@eipg.fr"