summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2017-12-20 00:08:09 +0100
committer Willy Sudiarto Raharjo2017-12-21 02:19:33 +0100
commit5c03647093c54c114513d778e1d00ae78edc870a (patch)
tree23391aee1b342f07c4b2206964f3a08877eed6f7
parentac37e357b1cdec2b699cdff8c9f3a001f383d7b7 (diff)
downloadslackbuilds-5c03647093c54c114513d778e1d00ae78edc870a.tar.gz
games/vbam: Updated for version 2.0.1.
Signed-off-by: B. Watson <yalhcru@gmail.com>.
-rw-r--r--games/vbam/30b6ecf.diff87
-rw-r--r--games/vbam/4648638.diff54
-rw-r--r--games/vbam/vbam.SlackBuild20
-rw-r--r--games/vbam/vbam.info6
4 files changed, 157 insertions, 10 deletions
diff --git a/games/vbam/30b6ecf.diff b/games/vbam/30b6ecf.diff
new file mode 100644
index 0000000000..232339f3a0
--- /dev/null
+++ b/games/vbam/30b6ecf.diff
@@ -0,0 +1,87 @@
+diff --git a/CHANGELOG.md b/CHANGELOG.md
+new file mode 100644
+index 00000000..c24ac560
+--- /dev/null
++++ b/CHANGELOG.md
+@@ -0,0 +1,81 @@
++# Changelog
++All notable changes to this project will be documented in this file.
++
++The format is based on [Keep a Changelog](http://keepachangelog.com/en/1.0.0/)
++and this project adheres to [Semantic Versioning](http://semver.org/spec/v2.0.0.html).
++
++## [Unreleased]
++
++## [2.0.1] - 10/11/2017
++### Added
++- initial installer script
++- gitter.im badge in readme
++- 32bit cross compiling support on 64bit linux
++- added support for GNUInstallDirs to cmake
++- Include new translations from transifex
++- Added WxWidgets ABI compiler check
++- Add linux Joystick reference to issue template
++- Add #ubckyde <cmath> fir std::cell()
++-
++
++### Changed
++- Fix 2xSaImmx.asm linking issue
++- cmake: default to ENABLE_ASM_CORE=OFF
++- libretro merging from upstream libretro fork.
++- better fix for clipped video in GL Fullscreen.
++- Fix flibc crash: add log message on fopen failure
++- fix gameboy header-detection in libretro interface
++- hotfix for potential buffer-overflow
++- delete memory in common/array.h on destruction
++- SDL: improve error msg for unwritable config
++- SDL: fix deflt bat saving, improve dir checking
++- fix portability issue with strerror_r()
++- Windows doesn't have sterror_r
++- wx/wxvbam: fix GetAbsolutePath
++- fix a memory leak due to wrong syntax
++- regenerate translation files
++- fix errors reported by SUSE's post build linter
++- SUSE Lint: fix a few classes of warnings
++- let cmake escape -D preproc. definitions
++- fix memory viewer xrc on wx 3.1+
++- Improving README
++- SoundSDL: lock conditional code cleanup
++- remove the default F11 keybinding for save state
++- hopefully fix resize artifacts on game panel
++- soundSDL: write silence when paused
++- cleanup SoundSDL #139 #130 #97 #67 #65 #46 #47
++- document how to provice symbolic backtraces
++- "no throttle" fixes/cleanup
++- only use -mtune=generic on x86/amd64
++- installdeps: use -j$(nproc) not -j8 in info
++- use -fabi-version=2 for GCC turn off LTO
++- installdeps: minor refactoring/cleanup
++- improve Wx GCC ABI check
++- minor improvements for Wx Compile tests
++- fix wx ABI check for Win32/MinGW
++- installdeps: fedora fixes, including m32
++- cmake: wx and cross compiling fixes
++- restore wx 2.7 compat, improve string processing
++- rename CMakeScripts/ to cmake/
++- work around gcc lto wrappers bug with gcc 7.x
++- update README.md
++- remove doctoc title from README.md TOC
++- improve win32 dependencies git submodule handling
++- use num cpu cores to parallelize LTO link with gcc
++- fix huge app icon in Win volume settings
++- fix deadlock in SoundSDL:deinit()
++- added executable extension for sdl binary
++- default LTO to off on 64bit MinGW
++- minor code cleanup
++- deps: dont check result of apt-get update
++- read version and subversion info from Git
++- fix error and version info in shallow git clones
++- refactor/cleanup GitTagVersion.cmake
++
++### Removed
++- Cairo Renderer: it never performed well to begin with
++
++
++
++[2.0.1]: https://github.com/olivierlacan/keep-a-changelog/compare/throttle...v2.0.1
++
diff --git a/games/vbam/4648638.diff b/games/vbam/4648638.diff
new file mode 100644
index 0000000000..46af8dac20
--- /dev/null
+++ b/games/vbam/4648638.diff
@@ -0,0 +1,54 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bd09527d..4ad859b2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -112,15 +112,12 @@ if(GIT_FOUND AND EXISTS "${CMAKE_SOURCE_DIR}/.git")
+ # of files that depend on version.h
+ include(GetGitRevisionDescription)
+ get_git_head_revision(REFSPEC COMMITHASH)
+-else()
+- message(WARNING "Git not found, cannot set version info")
+ endif()
+
+-# no git or no tags
++# no git or no tags, use ChangeLog
+ if(NOT VERSION)
+- set(VERSION 2.0.0)
+- set(REVISION "unknown")
+- set(VERSION_RELEASE 0)
++ include(ChangeLogVersion)
++ changelog_version(VERSION REVISION VERSION_RELEASE)
+ endif()
+
+ # generate version.h
+diff --git a/cmake/ChangeLogVersion.cmake b/cmake/ChangeLogVersion.cmake
+new file mode 100644
+index 00000000..101d23bd
+--- /dev/null
++++ b/cmake/ChangeLogVersion.cmake
+@@ -0,0 +1,25 @@
++function(changelog_version version revision version_release)
++ set(${version} "" CACHE STRING "Latest ChangeLog Version" FORCE)
++ set(${revision} "" CACHE STRING "Latest ChangeLog Revision" FORCE)
++ set(${version_release} 0 CACHE STRING "Is this a versioned release without revision" FORCE)
++
++ file(READ CHANGELOG.md changelog_file)
++
++ if(NOT changelog_file)
++ return()
++ endif()
++
++ string(REGEX MATCH "\n## +\\[([0-9.]+)(-([^] ]+))?\\] +- +[0-9][0-9]?/" match_out "${changelog_file}")
++
++ set(changelog_version "${CMAKE_MATCH_1}")
++
++ set(is_version_release 0)
++ set(changelog_revision "${CMAKE_MATCH_3}")
++ if(NOT changelog_revision)
++ set(is_version_release 1)
++ endif()
++
++ set(${version} "${changelog_version}" CACHE STRING "Latest ChangeLog Version" FORCE)
++ set(${revision} "${changelog_revision}" CACHE STRING "Latest ChangeLog Revision" FORCE)
++ set(${version_release} "${is_version_release}" CACHE STRING "Is this a versioned release without revision" FORCE)
++endfunction()
diff --git a/games/vbam/vbam.SlackBuild b/games/vbam/vbam.SlackBuild
index 44c0fa3d50..d7249c4475 100644
--- a/games/vbam/vbam.SlackBuild
+++ b/games/vbam/vbam.SlackBuild
@@ -23,6 +23,8 @@
# Modified by the SlackBuilds.org project.
+# 20171219 bkw: updated for 2.0.1.
+
# 20170302 bkw: use long-format github URL
# 20170126 bkw:
@@ -41,11 +43,11 @@
# - Correct README, plus cosmetic reformatting.
PRGNAM=vbam
-VERSION=${VERSION:-2.0.0beta3}
+VERSION=${VERSION:-2.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-SRCVER="Beta-3"
+SRCVER="$VERSION"
SRCNAM="visualboyadvance-m"
# Set to ON to enable FFMPEG A/V recording.
@@ -102,11 +104,11 @@ find -L . \
# confusion, force the correct version.
WXCONF=${WXCONF:-/usr/lib$LIBDIRSUFFIX/wx/config/gtk2-unicode-3.0}
-# install binary to /usr/games, since it's got a section 6 man page.
-sed -i '/DESTINATION bin/s,bin,games,' CMakeLists.txt
-
-# man pages go in Slack standard location.
-sed -i 's,share/man,man,g' CMakeLists.txt
+# Upstream says: "Note to distro packagers: If you build from a tarball
+# rather than from git, please include 30b6ecf and 4648638 as patches. These
+# didn't make it into the tag."
+patch -p1 < $CWD/30b6ecf.diff
+patch -p1 < $CWD/4648638.diff
mkdir -p build
cd build
@@ -120,6 +122,10 @@ cd build
-DENABLE_FFMPEG=${FFMPEG} \
-DCMAKE_BUILD_TYPE=Release ..
make
+ sed -i \
+ -e 's,/usr/share/man,/usr/man,g' \
+ -e 's,/usr/bin,/usr/games,g' \
+ cmake_install.cmake
make install DESTDIR=$PKG
cd ..
diff --git a/games/vbam/vbam.info b/games/vbam/vbam.info
index a0bebd98f4..6124ba5d0a 100644
--- a/games/vbam/vbam.info
+++ b/games/vbam/vbam.info
@@ -1,8 +1,8 @@
PRGNAM="vbam"
-VERSION="2.0.0beta3"
+VERSION="2.0.1"
HOMEPAGE="http://vba-m.com/"
-DOWNLOAD="https://github.com/visualboyadvance-m/visualboyadvance-m/archive/Beta-3/visualboyadvance-m-Beta-3.tar.gz"
-MD5SUM="0b722fb702a34015dc4b37b57679ad20"
+DOWNLOAD="https://github.com/visualboyadvance-m/visualboyadvance-m/archive/v2.0.1/visualboyadvance-m-2.0.1.tar.gz"
+MD5SUM="b5147a34de3e2cd878c354aac37a7bcc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="SDL2 SFML wxGTK3"