summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2021-04-10 05:22:53 +0200
committer Willy Sudiarto Raharjo2021-04-10 12:04:43 +0200
commit375f4610c19543281643443207c438eb38ae9fb6 (patch)
tree00f179d6166de33ae21d41837df753882dc755c4
parent58616c52fbccab8e70c89cb4c9363029729023a8 (diff)
downloadslackbuilds-375f4610c19543281643443207c438eb38ae9fb6.tar.gz
development/QtPy: Added (Qt abstraction layer for Python)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/QtPy/QtPy.SlackBuild87
-rw-r--r--development/QtPy/QtPy.info10
-rw-r--r--development/QtPy/README5
-rw-r--r--development/QtPy/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/development/QtPy/QtPy.SlackBuild b/development/QtPy/QtPy.SlackBuild
new file mode 100644
index 0000000000..6cff9f0c73
--- /dev/null
+++ b/development/QtPy/QtPy.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for QtPy
+
+# Copyright 2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=QtPy
+VERSION=${VERSION:-1.9.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS.md CHANGELOG.md LICENSE.txt README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/QtPy/QtPy.info b/development/QtPy/QtPy.info
new file mode 100644
index 0000000000..4454ad7be2
--- /dev/null
+++ b/development/QtPy/QtPy.info
@@ -0,0 +1,10 @@
+PRGNAM="QtPy"
+VERSION="1.9.0"
+HOMEPAGE="https://github.com/spyder-ide/QtPy"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/Q/QtPy/QtPy-1.9.0.tar.gz"
+MD5SUM="a7c993a82a1e0a0fbd01ef4aa924ed21"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-PyQt5"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/QtPy/README b/development/QtPy/README
new file mode 100644
index 0000000000..8bdc7dc48c
--- /dev/null
+++ b/development/QtPy/README
@@ -0,0 +1,5 @@
+QtPy is a small abstraction layer that lets you write applications using
+a single API call to either PyQt or PySide.
+
+It provides support for PyQt5, PyQt4, PySide2 and PySide using the Qt5
+layout (where the QtGui module has been split into QtGui and QtWidgets).
diff --git a/development/QtPy/slack-desc b/development/QtPy/slack-desc
new file mode 100644
index 0000000000..ed92f3ef1e
--- /dev/null
+++ b/development/QtPy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+QtPy: QtPy (Qt abstraction layer for Python)
+QtPy:
+QtPy: QtPy is a small abstraction layer that lets you write applications
+QtPy: using a single API call to either PyQt or PySide.
+QtPy:
+QtPy: It provides support for PyQt5, PyQt4, PySide2 and PySide using the
+QtPy: Qt5 layout (where the QtGui module has been split into QtGui and
+QtPy: QtWidgets).
+QtPy:
+QtPy:
+QtPy: