summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2021-06-19 13:57:03 +0200
committer Willy Sudiarto Raharjo2021-06-19 13:57:03 +0200
commit119327fd24bf95190041f52a0501b6a93292f5ac (patch)
tree95e44747786a4b4f638e324027167c7a9f9f6246
parenteebb78deb3bc4d1f31282da08edabea8095c3148 (diff)
downloadslackbuilds-119327fd24bf95190041f52a0501b6a93292f5ac.tar.gz
libraries/wxPython3: Fix build with wxGTK3 changes.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/wxPython3/README2
-rw-r--r--libraries/wxPython3/wxPython3.SlackBuild35
-rw-r--r--libraries/wxPython3/wxPython3.info2
3 files changed, 14 insertions, 25 deletions
diff --git a/libraries/wxPython3/README b/libraries/wxPython3/README
index 26a0ae22bf..3a3826baea 100644
--- a/libraries/wxPython3/README
+++ b/libraries/wxPython3/README
@@ -21,4 +21,4 @@ package and wx-config will point to correct version. The same solution
can be used if wxPython's wx-config is overwritten.
Optional dependency:
-- To have webview support, please install webkitgtk before installing wxGTK3.
+- To have webview support, please install webkit2gtk before installing wxGTK3.
diff --git a/libraries/wxPython3/wxPython3.SlackBuild b/libraries/wxPython3/wxPython3.SlackBuild
index 4284135177..551e3751e8 100644
--- a/libraries/wxPython3/wxPython3.SlackBuild
+++ b/libraries/wxPython3/wxPython3.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for wxPython3
# Copyright 2007-2014 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2016-2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
PRGNAM=wxPython3
SRCNAM=wxPython
VERSION=${VERSION:-3.0.2.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,7 +57,7 @@ else
fi
# check webkitgtk existence
-webkit=`pkg-config --exists webkit-1.0`
+webkit=`pkg-config --exists webkit2gtk-4.0`
if [ "$?" -eq 0 ]; then
wx="--enable-webview"
else
@@ -86,15 +86,17 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static \
- --with-gtk=2 \
+ --with-gtk=3 \
--with-sdl \
--with-opengl \
--enable-unicode \
--enable-graphics_ctx \
--enable-display \
--enable-mediactrl \
+ --enable-graphics_ctx \
--enable-sound \
--disable-precomp-headers \
+ --with-wx-config=/usr/bin/wx-config \
--libdir=/usr/lib$LIBDIRSUFFIX \
--build=$ARCH-slackware-linux \
$wx
@@ -102,29 +104,16 @@ CXXFLAGS="$SLKCFLAGS" \
make
cd wxPython
- python setup.py \
- WXPORT=gtk2 \
+ python2 setup.py \
+ WXPORT=gtk3 \
UNICODE=1 \
- EP_ADD_OPTS=1 \
- EP_FULL_VER=0 \
- NO_SCRIPTS=0 \
- WX_CONFIG="$TMP/$SRCNAM-src-$VERSION/wx-config --no_rpath" \
- build_ext --include-dirs=$TMP/$PRGNAM-src-$VERSION/lib/wx/include/gtk2-unicode-release-2.8 \
- --library-dirs=$TMP/$PRGNAM-src-$VERSION/lib \
- --rpath=/usr/lib$LIBDIRSUFFIX \
+ WX_CONFIG=/usr/bin/wx-config \
build
- python setup.py \
- WXPORT=gtk2 \
+ python2 setup.py \
+ WXPORT=gtk3 \
UNICODE=1 \
- EP_ADD_OPTS=1 \
- EP_FULL_VER=0 \
- NO_SCRIPTS=0 \
- WX_CONFIG="$TMP/$SRCNAM-src-$VERSION/wx-config --prefix=$PKG/usr/bin/ --no_rpath" \
- SYS_WX_CONFIG="wx-config --enable-unicode" \
- build_ext --include-dirs=$TMP/$PRGNAM-src-$VERSION/lib/wx/include/gtk2-unicode-release-2.8 \
- --library-dirs=$TMP/$PRGNAM-src-$VERSION/lib \
- --rpath=/usr/lib$LIBDIRSUFFIX \
+ WX_CONFIG=/usr/bin/wx-config \
install --root=$PKG
mkdir -p $PKG/usr/share/{applications,pixmaps} $PKG/usr/share/icons/hicolor/{16x16,32x32}/apps
diff --git a/libraries/wxPython3/wxPython3.info b/libraries/wxPython3/wxPython3.info
index a2d670dcb9..781a4672a4 100644
--- a/libraries/wxPython3/wxPython3.info
+++ b/libraries/wxPython3/wxPython3.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://sourceforge.net/projects/wxpython/files/wxPython/3.0.2.0/wxPyt
MD5SUM="922b02ff2c0202a7bf1607c98bbbbc04"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="wxGTK3"
+REQUIRES="wxGTK3 gst0-plugins-base"
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"