summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Christoph Willing2023-04-08 07:29:52 +0200
committer Willy Sudiarto Raharjo2023-04-15 02:15:44 +0200
commit0449fb4fac6e732cd39a2b8685150ac8f6b36e94 (patch)
tree936dac5b81dd149cb39ee0c7177efcd38b286f16
parentcbd1879709ae571c0d0b7511db5f0b1bb4123bca (diff)
downloadslackbuilds-0449fb4fac6e732cd39a2b8685150ac8f6b36e94.tar.gz
office/LibreOffice: Handle incompatible system boost
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--office/LibreOffice/LibreOffice.SlackBuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/office/LibreOffice/LibreOffice.SlackBuild b/office/LibreOffice/LibreOffice.SlackBuild
index cc07b689fb..f83835d9cd 100644
--- a/office/LibreOffice/LibreOffice.SlackBuild
+++ b/office/LibreOffice/LibreOffice.SlackBuild
@@ -30,7 +30,7 @@ PRGNAM=LibreOffice
SRCNAM=libreoffice
VERSION=${VERSION:-7.5.2.2}
SHORT_VERSION=${VERSION%.*.*}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -189,6 +189,16 @@ extwikipub="--enable-ext-wiki-publisher"; [ "${EXTWIKIPUB:-no}" != "yes" ] &
extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] && extnlpsolver=""
+# Temporary fix for problems with boost > 1.80
+# Results in additional download of compatible boost to use internally
+BOOST_MINOR_VERSION=$(basename $(ls -d /usr/lib${LIBDIRSUFFIX}/cmake/Boost-1.*) | cut -d'.' -f2)
+if [ "$BOOST_MINOR_VERSION" -gt "80" ]; then
+ boost="--without-system-boost"
+else
+ boost="--with-system-boost"
+fi
+
+
./configure \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -222,7 +232,6 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
--without-junit \
--with-help \
--with-system-bluez \
- --with-system-boost \
--with-system-bzip2 \
--with-system-cairo \
--with-system-clucene \
@@ -249,6 +258,7 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
--with-system-poppler \
--with-system-sane \
--with-system-zlib \
+ $boost \
$coinmp \
$cppunit \
$glm \
@@ -298,7 +308,6 @@ sed -i external/libebook/ExternalProject_libebook.mk \
-e '/configure /i \\t\t&& sed -i "s/TRUE/true/g" src/lib/EBOOKCharsetConverter.cpp \\'
-export LDFLAGS="-lboost_system"
make build
make distro-pack-install DESTDIR=$PKG