summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2021-09-13 17:12:53 +0200
committer Willy Sudiarto Raharjo2021-09-15 19:45:33 +0200
commit0298e07868a603c46addbcf82abdbd9947196cb0 (patch)
tree89d0dd74e8acb39eb6a1aa7465dd44968a40750a
parentf6741cc546e0c247cb7bee2894118d777cc76daf (diff)
downloadslackbuilds-0298e07868a603c46addbcf82abdbd9947196cb0.tar.gz
games/minetest: Updated for version 5.4.1, patch for gcc >= 11.x.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/minetest/gcc11.patch21
-rw-r--r--games/minetest/minetest.SlackBuild4
-rw-r--r--games/minetest/minetest.info6
3 files changed, 27 insertions, 4 deletions
diff --git a/games/minetest/gcc11.patch b/games/minetest/gcc11.patch
new file mode 100644
index 0000000000..bb37cdf31e
--- /dev/null
+++ b/games/minetest/gcc11.patch
@@ -0,0 +1,21 @@
+From 7c2826cbc0f36027d4a9781f433150d1c5d0d03f Mon Sep 17 00:00:00 2001
+From: lhofhansl <larsh@apache.org>
+Date: Thu, 6 May 2021 10:24:30 -0700
+Subject: [PATCH] Fix build for newer versions of GCC (#11246)
+
+---
+ src/clientiface.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/clientiface.h b/src/clientiface.h
+index cc5292b71bf9..dfd97674137c 100644
+--- a/src/clientiface.h
++++ b/src/clientiface.h
+@@ -31,6 +31,7 @@ with this program; if not, write to the Free Software Foundation, Inc.,
+ #include <list>
+ #include <vector>
+ #include <set>
++#include <memory>
+ #include <mutex>
+
+ class MapBlock;
diff --git a/games/minetest/minetest.SlackBuild b/games/minetest/minetest.SlackBuild
index b223d9d1e6..4563795705 100644
--- a/games/minetest/minetest.SlackBuild
+++ b/games/minetest/minetest.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=minetest
-VERSION=${VERSION:-5.3.0}
+VERSION=${VERSION:-5.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,6 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/gcc11.patch
+
# Fix man page path
sed -i "s/share\/man/man/" CMakeLists.txt
diff --git a/games/minetest/minetest.info b/games/minetest/minetest.info
index 9912cdb1cd..6aaa220910 100644
--- a/games/minetest/minetest.info
+++ b/games/minetest/minetest.info
@@ -1,8 +1,8 @@
PRGNAM="minetest"
-VERSION="5.3.0"
+VERSION="5.4.1"
HOMEPAGE="http://minetest.net/"
-DOWNLOAD="https://github.com/minetest/minetest/archive/5.3.0/minetest-5.3.0.tar.gz"
-MD5SUM="858ac78e732e54b1d0d70e2f1a7026f7"
+DOWNLOAD="https://github.com/minetest/minetest/archive/5.4.1/minetest-5.4.1.tar.gz"
+MD5SUM="1814139a9b82aa07ad89867095224b4d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="irrlicht luajit jsoncpp"