summaryrefslogtreecommitdiffstats
path: root/system/heirloom-sh/heirloom-sh.SlackBuild
blob: b805981e575f7ee3f86b68f455972d4fd65becfd (plain)
#!/bin/bash

# Slackware build script for heirloom-sh
# Written by slakmagik <slakmagik@gmail.com>
# Released under the WTFPL

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=heirloom-sh
VERSION=${VERSION:-050706}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
  \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  -exec chmod 755 {} \; -o \
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
  -o -perm 400 \) -exec chmod 644 {} \;

# configure is the worst way to build a package except for all the others
# 1. make static changes to the makefile with a patch
patch -p1 < $CWD/makefile.patch
# 2. make dynamic changes to the makefile with sed
sed -i~ "/^CFLAGS=/s:-O:$SLKCFLAGS:;/^ROOT=/s:$:$PKG:" makefile
# 3. make static changes to the manpage with sed (easier maintenance)
sed -i~ 's/\<sh\>/h&/g;s/\<Sh\>/Hsh/g;s/\\fBsh\\fR/\\fBhsh\\fR/' sh.1

# the makefile autostrips
make install

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $(find $PKG/usr/man -type l); do
  ln -s $(readlink $i).gz $i.gz; rm $i
done

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a [COR]* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE