summaryrefslogtreecommitdiffstats
path: root/network/rhapsody/rhapsody.SlackBuild
blob: 8c034dd4eb6d105b1ef588b5aa09914cac7792de (plain)
#!/bin/bash

# Slackware build script for rhapsody

# Written by B. Watson (urchlay@slackware.uk)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20210923 bkw: fix build on -current, mitigate buffer overflow.

# TODO: see if there's anything to these:
# https://www.cvedetails.com/cve/CVE-2007-1502/
# https://www.cvedetails.com/cve/CVE-2007-1503/
# ...these appear to be the same CVE. Huh.
# It looks autogenerated, and there's no POC. Pretty much all the
# buffer overflows would depend on the user typing >1024 characters.
# The patch below prevents that, at least. There are a bunch of
# format string warnings from gcc that deserve looking at, but I
# don't have the time right now.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=rhapsody
VERSION=${VERSION:-0.28b}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

LIBPATH=/usr/lib
if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}_$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# This patch does:
# - prevent input buffer overflow if user types/pastes > 1023 chars
#   into the input window.
# - ignore incoming DCC files, if their names contain a /
patch -p1 < $CWD/securityfix.diff

./configure -i /usr/bin -d /usr/doc/$PRGNAM-$VERSION
make LOCALFLAGS="$SLKCFLAGS -fcommon"
strip $PRGNAM
make install \
  INSTALLPATH=$PKG/usr/bin \
  INSTDOCSPATH=$PKG/usr/doc/$PRGNAM-$VERSION

cp README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

# Man page borrowed from Ubuntu and modified a bit.
# rhapsody doesn't really need a man page,
# but I like the "every binary has a man page" approach...
mkdir -p $PKG/usr/man/man1
sed "s/@VERSION@/$VERSION/g" < $CWD/$PRGNAM.1 | \
  gzip -9c - > $PKG/usr/man/man1/$PRGNAM.1.gz

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE