summaryrefslogtreecommitdiffstats
path: root/misc/dwdiff/dwdiff.SlackBuild
blob: 1a9690b08d7e90a75a64a5f034b2bb18dd56e77f (plain)
#!/bin/bash

# Slackware build script for dwdiff
# Written by slakmagik <slakmagik@gmail.com>
# Released under the WTFPL

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=dwdiff
VERSION=${VERSION:-2.1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

if [ -z "$UNICODE" ]; then
  UNICODE=without
else
  UNICODE=with
fi
NLS="${NLS:-""}"

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
  \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  -exec chmod 755 {} \; -o \
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
  -o -perm 400 \) -exec chmod 644 {} \;

# Patch for configure --mandir
patch -p1 < $CWD/config.pkg.patch
# Patch for a build failure if not building with unicode.
patch -p1 < $CWD/src-option.c.patch

# This is one messed up makefile - and its configure doesn't accept '--build'
CC="gcc -fgnu89-inline" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --$UNICODE-unicode \
  --prefix=/usr \
  --mandir='$(prefix)/man'

make LINGUAS="$NLS" prefix=/usr
make LINGUAS="$NLS" prefix=$PKG/usr install

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF |
  cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

find $PKG/usr/man -type f -exec gzip -9 {} \;

mv $PKG/usr/share/doc $PKG/usr
if [ -z "$NLS" ]; then # share/ will be empty
  rmdir $PKG/usr/share
fi
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE