summaryrefslogtreecommitdiffstats
path: root/games/xroar/xroar.SlackBuild
blob: d582bbdeb983559d6cbbb7fe22ee8bfd1fd30859 (plain)
#!/bin/sh

# Slackware build script for xroar

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20181201 bkw: update for 0.35.2

# 20180828 bkw:
# - update for 0.35
# - build with --without-oss by default, add OSS=yes option
# - get rid of alsa_first.diff (doesn't apply any more anyway)
# - add PULSE=no option
# - move cruft out of here & into ChangeLog.old
# - SDL 1.x build broke in 0.35, so remove SDL2=no and add SDL2
#   to REQUIRES.

# 20170822 bkw:
# - update for 0.34.8
# - add SDL2=no and GTKGLEXT=no options, mostly for my own testing
# - record build options in slack-desc

# 20170122 bkw: update for 0.34.7

PRGNAM=xroar
VERSION=${VERSION:-0.35.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# Most users will want to leave OSS and PULSE alone.

# Can't check ldd output to see if OSS is built-in, so take
# some care to leave the value of OSS presentable for use in
# the slack-desc.
OSS="${OSS:-no}"
case "$OSS" in
  y*|Y*) OSS=yes ;;
  *)     OSS=no  ;;
esac

[ "$OSS"          = "yes" ] ||   OSSOPT="--without-oss"
[ "${PULSE:-yes}" = "yes" ] || PULSEOPT="--without-pulse"

# Not sure why anyone would need this, but it's easy to support.
JACKOPT="--without-jack"
[ "${JACK:-no}" = "yes" ] && JACKOPT="--with-jack"

# 20180829 bkw: SDL 1.x build is broken in xroar-0.35!  If upstream
# fixes it, uncomment the SDL2 check below, remove SDL2 from REQUIRES
# in the .info file, and re-add this to the README:

## SDL2 - if you prefer SDL2 to SDL1, install SDL2 before building xroar.
##   I haven't noticed any difference between xroar built with SDL1 or SDL2,
##   but the option is there in case you need it. If SDL2 is installed,
##   you can build without it by setting SDL2=no in the environment.

#[ "${SDL2:-yes}" = "no" ] && SDL2OPT="--without-sdl2"

[ "${GTKGLEXT:-yes}" = "no" ] && GTKGLOPT="--without-gtkgl"

# fix underlinking via LDFLAGS instead of a .diff

LDFLAGS="-lm" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  $OSSOPT $PULSEOPT $JACKOPT $SDL2OPT $GTKGLOPT \
  --bindir=/usr/games \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --build=$ARCH-slackware-linux

make
make install DESTDIR=$PKG
strip $PKG/usr/games/$PRGNAM

# set these for use in the slack-desc
SDLVER=1.2
JACK=no
GTKGLEXT=no
PULSE=no
ldd $PKG/usr/games/$PRGNAM > ldd.tmp
grep -q libSDL2 ldd.tmp     && SDLVER=2.0
grep -q libjack ldd.tmp     && JACK=yes
grep -q libgtkglext ldd.tmp && GTKGLEXT=yes
grep -q libpulse.so ldd.tmp && PULSE=yes

# man page needs to be in section 6, since this is in games/
mkdir -p $PKG/usr/man/man6
sed '1s,\<1\>,6,' \
  < $PKG/usr/man/man1/$PRGNAM.1 \
  | gzip -9c > $PKG/usr/man/man6/$PRGNAM.6.gz
rm -rf $PKG/usr/man/man1

mv $PKG/usr/share/info $PKG/usr/info
rm -rf $PKG/usr/share
rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*.info*

mkdir -p $PKG/usr/share/xroar/roms

# Mini-firmware. This is a freeware, incomplete implementation of the
# Dragon32 extended BASIC, allows running at least some programs.
# dragon.rom comes from http://www.6809.org.uk/dragon/dragon.rom
cat $CWD/dragon.rom > $PKG/usr/share/$PRGNAM/roms/mini-dragon.rom

ROMS="mini-dragon"
# Optional ROM images (from MESS site)
for zip in coco coco2 cocoe dragon32 dragon64; do
  if [ -e $CWD/$zip.zip ]; then
    rm -f *.rom
    unzip $CWD/$zip.zip
    install -oroot -groot -m0644 *.rom $PKG/usr/share/$PRGNAM/roms
    ROMS="$ROMS $zip"
  fi
done

# If the user doesn't include a d32.rom from a zip file, make the mini-rom
# the default (at least the emu will start, that way)
if [ ! -e $PKG/usr/share/$PRGNAM/roms/d32.rom ]; then
  ln -s mini-dragon.rom $PKG/usr/share/$PRGNAM/roms/d32.rom
fi

# Icon taken from Fedora package here:
# ftp://mirror.switch.ch/pool/3/mirror/rpmfusion/free/fedora/updates/8/i386/xroar-0.21-2.fc8.i386.rpm
# Current versions of xroar include windows and mac icons that are larger,
# but they don't include the word 'xroar' (just the X-shaped graphic), so
# I'm sticking with the old Fedora icon.
mkdir $PKG/usr/share/pixmaps
cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png

mkdir $PKG/usr/share/applications
cp $CWD/*.desktop $PKG/usr/share/applications

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
# Don't bother with the README: it's only about installation, not usage
cp -a COPYING* ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION

# HTML version of the info page, for those who hate info pages...
( cd doc && make $PRGNAM.html )
cp doc/$PRGNAM.html doc/*png $PKG/usr/doc/$PRGNAM-$VERSION

cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
sed -e "s,@JACK@,$JACK," \
    -e "s,@SDLVER@,$SDLVER," \
    -e "s,@GTKGLEXT@,$GTKGLEXT," \
    -e "s,@ROMS@,$ROMS," \
    -e "s,@PULSE@,$PULSE," \
    -e "s,@OSS@,$OSS," \
    $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}