summaryrefslogtreecommitdiffstats
path: root/games/qzdl/qzdl.SlackBuild
blob: 2f478bb37ba8d593e77a5ea1e96296c2b251896b (plain)
#!/bin/bash

# Slackware build script for qzdl
#
# Copyright 2015 Gethyn ThomasQuail <email removed>
# Copyright 2020 B. Watson
# All rights reserved.
#
# Based on:
# SBo's cmake-template
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20230107 bkw: BUILD=2, add doinst.sh.

# 20211209 bkw:
# - update for latest git, 3.2.2.3+20211008_9c76408. needed for building
#   on -current.
# - new-style icons.

# 20200416 bkw:
# - take over maintenance
# - binaries in /usr/games
# - symlink icon to /usr/share/icons
# - various tweaks

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=qzdl
VERSION=${VERSION:-3.2.2.3+20211008_9c76408}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L .  -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
        \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+

# 20211209 bkw: FETCHCONTENT_FULLY_DISCONNECTED stops it trying
# to do a git clone of its dependency 'inih'. Means we have to
# already have inih source in our tarball; see git2tarxz.sh.
mkdir -p build
cd build
  cmake \
    -DFETCHCONTENT_FULLY_DISCONNECTED=ON \
    -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_BUILD_TYPE=Release ..
  make
cd ..

# no install or install/strip targets.
mkdir -p $PKG/usr/games
install -s -m0755 build/zdl $PKG/usr/games
ln -s zdl $PKG/usr/games/$PRGNAM

HICOLOR=$PKG/usr/share/icons/hicolor
PIXMAPS=$PKG/usr/share/pixmaps
APPS=$PKG/usr/share/applications

mkdir -p $APPS $PIXMAPS $HICOLOR/{48x48,scalable}/apps

cp $CWD/qzdl.desktop $APPS
cp -a res/zdl3.svg $HICOLOR/scalable/apps
for px in 16 32 48 64 128; do
  size=${px}x${px}
  dir=$PKG/usr/share/icons/hicolor/$size/apps
  mkdir -p $dir
  if [ -e res/zdl3-$size.png ]; then
    echo "=== copy $size"
    cp -a res/zdl3-$size.png $dir/$PRGNAM.png
  else
    echo "=== convert $size"
    convert -resize $size res/zdl3-1024x1024.png $dir/$PRGNAM.png
  fi
done

ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PIXMAPS/$PRGNAM.png

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS CHANGELOG LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE