summaryrefslogtreecommitdiffstats
path: root/system/sdl-jstest/no_sdl2.diff
diff options
context:
space:
mode:
Diffstat (limited to 'system/sdl-jstest/no_sdl2.diff')
-rw-r--r--system/sdl-jstest/no_sdl2.diff16
1 files changed, 9 insertions, 7 deletions
diff --git a/system/sdl-jstest/no_sdl2.diff b/system/sdl-jstest/no_sdl2.diff
index 51738bfc40..5a008d15fa 100644
--- a/system/sdl-jstest/no_sdl2.diff
+++ b/system/sdl-jstest/no_sdl2.diff
@@ -1,7 +1,7 @@
-diff -Naur sdl-jstest-20150806git/CMakeLists.txt sdl-jstest-20150806git.patched/CMakeLists.txt
---- sdl-jstest-20150806git/CMakeLists.txt 2015-09-15 02:46:06.000000000 -0400
-+++ sdl-jstest-20150806git.patched/CMakeLists.txt 2015-09-15 02:55:53.000000000 -0400
-@@ -22,7 +22,6 @@
+diff -Naur sdl-jstest-20160824git/CMakeLists.txt sdl-jstest-20160824git.patched/CMakeLists.txt
+--- sdl-jstest-20160824git/CMakeLists.txt 2016-10-17 15:36:01.184523186 -0400
++++ sdl-jstest-20160824git.patched/CMakeLists.txt 2016-10-17 15:44:48.393556770 -0400
+@@ -23,7 +23,6 @@
find_package(SDL REQUIRED)
find_package(PkgConfig REQUIRED)
@@ -9,10 +9,11 @@ diff -Naur sdl-jstest-20150806git/CMakeLists.txt sdl-jstest-20150806git.patched/
find_program(DOCBOOK2XMAN docbook2x-man)
if(DOCBOOK2XMAN)
-@@ -43,11 +42,6 @@
+@@ -44,12 +43,6 @@
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
endif()
+-link_directories(${SDL2_LIBRARY_DIRS})
-add_executable(sdl2-jstest sdl2-jstest.c)
-target_link_libraries(sdl2-jstest ${SDL2_LIBRARIES} ${CURSES_LIBRARIES})
-target_include_directories(sdl2-jstest PUBLIC ${SDL2_INCLUDE_DIRS} ${CURSES_INCLUDE_DIR})
@@ -21,10 +22,11 @@ diff -Naur sdl-jstest-20150806git/CMakeLists.txt sdl-jstest-20150806git.patched/
add_executable(sdl-jstest sdl-jstest.c)
target_link_libraries(sdl-jstest ${SDL_LIBRARY} ${CURSES_LIBRARIES})
target_include_directories(sdl-jstest PUBLIC ${SDL_INCLUDE_DIR} ${CURSES_INCLUDE_DIR})
-@@ -59,22 +53,17 @@
+@@ -60,23 +53,17 @@
+ COMMAND ${DOCBOOK2XMAN} ${CMAKE_CURRENT_SOURCE_DIR}/sdl-jstest.xml
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/sdl-jstest.xml
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
-
+-
- add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/sdl2-jstest.1
- COMMAND ${DOCBOOK2XMAN} ${CMAKE_CURRENT_SOURCE_DIR}/sdl2-jstest.xml