summaryrefslogtreecommitdiffstats
path: root/system/pbzip2/pbzip2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/pbzip2/pbzip2.SlackBuild')
-rw-r--r--system/pbzip2/pbzip2.SlackBuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/system/pbzip2/pbzip2.SlackBuild b/system/pbzip2/pbzip2.SlackBuild
new file mode 100644
index 0000000000..b4e34c3bb8
--- /dev/null
+++ b/system/pbzip2/pbzip2.SlackBuild
@@ -0,0 +1,47 @@
+#!/bin/sh
+
+# Slackware build script for PBZIP2
+# Written by Erik Hanson erik@slackbuilds.org
+
+PRGNAM=pbzip2
+VERSION=1.0
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Patch to add march/mtune
+patch -p0 < $CWD/Makefile.patch
+make || exit 1
+
+# DESTDIR isn't support, there's only 2 files so install manually
+mkdir -p $PKG/usr/{bin,man/man1,doc/$PRGNAM-$VERSION} $PKG/install
+
+# Binary
+cp pbzip2 $PKG/usr/bin/pbzip2
+strip --strip-unneeded $PKG/usr/bin/pbzip2 2> /dev/null
+chmod a+x $PKG/usr/bin/pbzip2
+
+# Man page
+cp pbzip2.1 $PKG/usr/man/man1
+gzip -9 $PKG/usr/man/man1/pbzip2.1
+chmod a+r $PKG/usr/man/man1/pbzip2.1.gz
+
+cp -a AUTHORS COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz