summaryrefslogtreecommitdiffstats
path: root/python/tweepy/tweepy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/tweepy/tweepy.SlackBuild')
-rw-r--r--python/tweepy/tweepy.SlackBuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/python/tweepy/tweepy.SlackBuild b/python/tweepy/tweepy.SlackBuild
index b5d8a1dbd7..7d2acbcb2c 100644
--- a/python/tweepy/tweepy.SlackBuild
+++ b/python/tweepy/tweepy.SlackBuild
@@ -24,14 +24,14 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tweepy
-VERSION=${VERSION:-3.1.0}
+VERSION=${VERSION:-3.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -63,12 +63,9 @@ else
LIBDIRSUFFIX=""
fi
-PYTHON=python
-[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
-
DOCS="CHANGELOG.md CONTRIBUTORS LICENSE README.md"
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -83,13 +80,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# https://github.com/tweepy/tweepy/issues/533
-patch -p1 < $CWD/update_req_for_pip6.patch
-
-# we have six=1.8.0 and requests-oauthlib=0.4.2, so we cheat
-sed -i -e "s|1\.7\.3|1.8.0|" -e "s|0\.4\.1|0.4.2|" requirements.txt
-
python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true