summaryrefslogtreecommitdiffstats
path: root/python/python3-eventlib
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-eventlib')
-rw-r--r--python/python3-eventlib/README7
-rw-r--r--python/python3-eventlib/python3-eventlib.SlackBuild100
-rw-r--r--python/python3-eventlib/python3-eventlib.info10
-rw-r--r--python/python3-eventlib/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/python/python3-eventlib/README b/python/python3-eventlib/README
new file mode 100644
index 0000000000..00008058bc
--- /dev/null
+++ b/python/python3-eventlib/README
@@ -0,0 +1,7 @@
+python3-eventlib is an AGProjects own way of
+connecting "twisted" and "greenlet" tools
+for Python.
+
+This is the version for python3.
+Its primary aim is to be a dependency for
+blink-qt
diff --git a/python/python3-eventlib/python3-eventlib.SlackBuild b/python/python3-eventlib/python3-eventlib.SlackBuild
new file mode 100644
index 0000000000..96038610db
--- /dev/null
+++ b/python/python3-eventlib/python3-eventlib.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-eventlib
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-eventlib
+VERSION=${VERSION:-0.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ NEWS README.sslwrap README.twisted TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-eventlib/python3-eventlib.info b/python/python3-eventlib/python3-eventlib.info
new file mode 100644
index 0000000000..c47da1ab2d
--- /dev/null
+++ b/python/python3-eventlib/python3-eventlib.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-eventlib"
+VERSION="0.3.0"
+HOMEPAGE="https://github.com/AGProjects/python3-eventlib"
+DOWNLOAD="https://github.com/AGProjects/python3-eventlib/archive/0.3.0/python3-eventlib-0.3.0.tar.gz"
+MD5SUM="367f46f3ba3c45f4aea37ed8d1516d60"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-eventlib_2023-09-22@lockywolf.net"
diff --git a/python/python3-eventlib/slack-desc b/python/python3-eventlib/slack-desc
new file mode 100644
index 0000000000..b47e871fb1
--- /dev/null
+++ b/python/python3-eventlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-eventlib: python3-eventlib (python3 bindings for twisted and greenlet)
+python3-eventlib:
+python3-eventlib: python3-eventlib is an AGProjects own way of connecting "twisted"
+python3-eventlib: and "greenlet" tools for Python.
+python3-eventlib:
+python3-eventlib: This is the version for python3. Its primary aim is to be a
+python3-eventlib: dependency for blink-qt.
+python3-eventlib:
+python3-eventlib:
+python3-eventlib:
+python3-eventlib: