summaryrefslogtreecommitdiffstats
path: root/python/python-uritemplate
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-uritemplate')
-rw-r--r--python/python-uritemplate/python-uritemplate.SlackBuild17
-rw-r--r--python/python-uritemplate/slack-desc2
2 files changed, 5 insertions, 14 deletions
diff --git a/python/python-uritemplate/python-uritemplate.SlackBuild b/python/python-uritemplate/python-uritemplate.SlackBuild
index 381d241e65..9112ea6b03 100644
--- a/python/python-uritemplate/python-uritemplate.SlackBuild
+++ b/python/python-uritemplate/python-uritemplate.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -82,17 +79,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.rst $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/python-uritemplate/slack-desc b/python/python-uritemplate/slack-desc
index da1c10ebd9..88234b1883 100644
--- a/python/python-uritemplate/slack-desc
+++ b/python/python-uritemplate/slack-desc
@@ -5,7 +5,7 @@
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
python-uritemplate: python-uritemplate (A python library)
python-uritemplate:
python-uritemplate: Simple python library to deal with URI Templates.