summaryrefslogtreecommitdiffstats
path: root/python/python-jeepney/python-jeepney.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-jeepney/python-jeepney.SlackBuild')
-rw-r--r--python/python-jeepney/python-jeepney.SlackBuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/python/python-jeepney/python-jeepney.SlackBuild b/python/python-jeepney/python-jeepney.SlackBuild
index 13396855e5..17c20a2f4a 100644
--- a/python/python-jeepney/python-jeepney.SlackBuild
+++ b/python/python-jeepney/python-jeepney.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-jeepney
# Copyright 2021 Andrew Clemons, Wellington New Zealand
+# Copyright 2023 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-jeepney
SRCNAM=jeepney
-VERSION=${VERSION:-0.7.1}
+VERSION=${VERSION:-0.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,7 +78,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true