summaryrefslogtreecommitdiffstats
path: root/python/pefile/pefile.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pefile/pefile.SlackBuild')
-rw-r--r--python/pefile/pefile.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/pefile/pefile.SlackBuild b/python/pefile/pefile.SlackBuild
index 3a8778cb40..7fce625b3f 100644
--- a/python/pefile/pefile.SlackBuild
+++ b/python/pefile/pefile.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for pefile
-# Copyright 2016-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2016-2023 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated for 2018.8.8 Jan 2019, Barry J. Grundy.
+# Updated for 2023.2.7, July 2023
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pefile
-VERSION=${VERSION:-2018.8.8}
+VERSION=${VERSION:-2023.2.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true