summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
Diffstat (limited to 'office')
-rw-r--r--office/evince/Remove-incorrect-args-for-i18n.merge_file.patch51
-rw-r--r--office/evince/evince.SlackBuild2
-rw-r--r--office/pstoedit/pstoedit-3.78-mga-uniqueptr.patch12
-rw-r--r--office/pstoedit/pstoedit.SlackBuild3
-rw-r--r--office/scribus/scribus.SlackBuild6
-rw-r--r--office/scribus/scribus.info6
-rw-r--r--office/zathura/meson-0.60.patch31
-rw-r--r--office/zathura/zathura.SlackBuild2
8 files changed, 106 insertions, 7 deletions
diff --git a/office/evince/Remove-incorrect-args-for-i18n.merge_file.patch b/office/evince/Remove-incorrect-args-for-i18n.merge_file.patch
new file mode 100644
index 0000000000..d444af8369
--- /dev/null
+++ b/office/evince/Remove-incorrect-args-for-i18n.merge_file.patch
@@ -0,0 +1,51 @@
+From: r-value <i@rvalue.moe>
+Date: Wed, 17 Nov 2021 18:22:45 +0800
+Subject: Remove incorrect args for i18n.merge_file
+
+`i18n.merge_file` has been ignoring positional arguments for
+a time and explicitly rejects with error since meson 0.60.0
+
+Origin: upstream, 42.0, commit:1060b24d051607f14220f148d2f7723b29897a54
+Bug-Debian: https://bugs.debian.org/1005520
+---
+ backend/meson.build | 1 -
+ data/meson.build | 1 -
+ meson.build | 1 -
+ 3 files changed, 3 deletions(-)
+
+diff --git a/backend/meson.build b/backend/meson.build
+index 14629f2..2f972a8 100644
+--- a/backend/meson.build
++++ b/backend/meson.build
+@@ -53,7 +53,6 @@ foreach backend, backend_mime_types: backends
+ )
+
+ i18n.merge_file(
+- appstream,
+ input: appstream_in,
+ output: appstream,
+ po_dir: po_dir,
+diff --git a/data/meson.build b/data/meson.build
+index 8a308b8..afc3020 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -15,7 +15,6 @@ foreach desktop: desktops
+ )
+
+ i18n.merge_file(
+- desktop,
+ type: 'desktop',
+ input: desktop_in,
+ output: desktop,
+diff --git a/meson.build b/meson.build
+index 07fb8ec..0bb5d0f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -498,7 +498,6 @@ install_headers(
+ appdata = ev_namespace + '.appdata.xml'
+
+ i18n.merge_file(
+- appdata,
+ input: appdata + '.in',
+ output: appdata,
+ po_dir: po_dir,
diff --git a/office/evince/evince.SlackBuild b/office/evince/evince.SlackBuild
index 8b706be14c..2cd205f7af 100644
--- a/office/evince/evince.SlackBuild
+++ b/office/evince/evince.SlackBuild
@@ -80,6 +80,8 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+patch -p1 < $CWD/Remove-incorrect-args-for-i18n.merge_file.patch
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
diff --git a/office/pstoedit/pstoedit-3.78-mga-uniqueptr.patch b/office/pstoedit/pstoedit-3.78-mga-uniqueptr.patch
new file mode 100644
index 0000000000..bca0f760dc
--- /dev/null
+++ b/office/pstoedit/pstoedit-3.78-mga-uniqueptr.patch
@@ -0,0 +1,12 @@
+Index: pstoedit-3.78/src/drvpptx.cpp
+===================================================================
+--- pstoedit-3.78/src/drvpptx.cpp
++++ pstoedit-3.78/src/drvpptx.cpp 2022-03-14 21:23:51.156263356 -0700
+@@ -35,6 +35,7 @@
+ #include I_stdlib
+ #include I_iomanip
+ #include <cfloat>
++#include <memory>
+ #include <time.h>
+
+ #include <errno.h>
diff --git a/office/pstoedit/pstoedit.SlackBuild b/office/pstoedit/pstoedit.SlackBuild
index fdc3fef7d8..406c7462f9 100644
--- a/office/pstoedit/pstoedit.SlackBuild
+++ b/office/pstoedit/pstoedit.SlackBuild
@@ -79,6 +79,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# https://sourceforge.net/p/pstoedit/patches/4/ Thanks to lioh!
+patch -p1 < $CWD/pstoedit-3.78-mga-uniqueptr.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -std=c++14" \
./configure \
diff --git a/office/scribus/scribus.SlackBuild b/office/scribus/scribus.SlackBuild
index c7e17f62e8..8b0469faa4 100644
--- a/office/scribus/scribus.SlackBuild
+++ b/office/scribus/scribus.SlackBuild
@@ -29,7 +29,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=scribus
-VERSION=${VERSION:-1.5.7}
+VERSION=${VERSION:-r25087}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,13 +83,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# thanks archlinux!
-patch -p1 < $CWD/harfbuzz-3.0.0.patch
-
cmake \
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DWANT_CPP17=1 \
-DLIB_SUFFIX=${LIBDIRSUFFIX}
make
diff --git a/office/scribus/scribus.info b/office/scribus/scribus.info
index f1b56cd8de..ed79a45fdf 100644
--- a/office/scribus/scribus.info
+++ b/office/scribus/scribus.info
@@ -1,8 +1,8 @@
PRGNAM="scribus"
-VERSION="1.5.7"
+VERSION="r25087"
HOMEPAGE="https://www.scribus.net"
-DOWNLOAD="https://downloads.sourceforge.net/scribus/scribus-1.5.7.tar.xz"
-MD5SUM="4d0c63cfdade8a9abf225a4415e43694"
+DOWNLOAD="https://ponce.cc/slackware/sources/repo/scribus-r25087.tar.xz"
+MD5SUM="df39329a17e35aca373b77602b001ebb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/office/zathura/meson-0.60.patch b/office/zathura/meson-0.60.patch
new file mode 100644
index 0000000000..e1e8260e66
--- /dev/null
+++ b/office/zathura/meson-0.60.patch
@@ -0,0 +1,31 @@
+From c6ec5044c5ff843979050bfb81742d14740bb656 Mon Sep 17 00:00:00 2001
+From: Sebastian Ramacher <sebastian@ramacher.at>
+Date: Sat, 30 Oct 2021 15:41:25 +0200
+Subject: [PATCH] Fix build with meson 0.60
+
+---
+ data/meson.build | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 4fd602eb..464ff3af 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -19,7 +19,7 @@ endif
+ i18n = import('i18n')
+ podir = join_paths(meson.project_source_root(), 'po')
+
+-desktop = i18n.merge_file('desktop',
++desktop = i18n.merge_file(
+ input: 'org.pwmt.zathura.desktop.in',
+ output: 'org.pwmt.zathura.desktop',
+ install: true,
+@@ -28,7 +28,7 @@ desktop = i18n.merge_file('desktop',
+ type: 'desktop'
+ )
+
+-appdata = i18n.merge_file('appdata',
++appdata = i18n.merge_file(
+ input: 'org.pwmt.zathura.appdata.xml.in',
+ output: 'org.pwmt.zathura.appdata.xml',
+ install: true,
diff --git a/office/zathura/zathura.SlackBuild b/office/zathura/zathura.SlackBuild
index 61c24d49df..ed15569418 100644
--- a/office/zathura/zathura.SlackBuild
+++ b/office/zathura/zathura.SlackBuild
@@ -90,6 +90,8 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
fixperms
+patch -p1 < $CWD/meson-0.60.patch
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \