summaryrefslogtreecommitdiffstats
path: root/office/asymptote
diff options
context:
space:
mode:
Diffstat (limited to 'office/asymptote')
-rw-r--r--office/asymptote/README6
-rw-r--r--office/asymptote/asymptote.SlackBuild41
-rw-r--r--office/asymptote/asymptote.info8
-rw-r--r--office/asymptote/doinst.sh3
-rw-r--r--office/asymptote/douninst.sh6
5 files changed, 47 insertions, 17 deletions
diff --git a/office/asymptote/README b/office/asymptote/README
index 5c81751106..56fc91cad6 100644
--- a/office/asymptote/README
+++ b/office/asymptote/README
@@ -4,3 +4,9 @@ Labels and equations are typeset with LaTeX, for high-quality PostScript
output.
A major advantage of Asymptote over other graphics packages is that it
is a programming language as opposed to just a graphics program.
+
+To build the complete documentation, install texlive-extra and set
+DOC=yes
+
+Optional dependencies for xasy(GUI):
+python3-numpy python3-cson
diff --git a/office/asymptote/asymptote.SlackBuild b/office/asymptote/asymptote.SlackBuild
index b3fc58ca1b..3a7ecea72e 100644
--- a/office/asymptote/asymptote.SlackBuild
+++ b/office/asymptote/asymptote.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for asymptote
-# Copyright 2016 - 2022 Johannes Schoepfer, Germany
+# Copyright 2016-2024 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=asymptote
-VERSION=${VERSION:-2.70}
+VERSION=${VERSION:-2.88}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +72,12 @@ cd asymptote-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+# To build the complete docs, some packages from texlive-extra are required.
+DOC=${DOC:-no}
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -89,17 +89,29 @@ CFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--enable-gc=system \
- --enable-offscreen \
+ --disable-offscreen \
+ --disable-lsp \
+ --disable-gc-debug \
+ --disable-gc-full-debug \
--with-latex=/usr/share/texmf-dist/tex/latex \
--with-context=/usr/share/texmf-dist/tex/context \
--datarootdir=/usr/share/texmf-dist \
--build=$ARCH-slackware-linux
+if [ $DOC = no ]; then
+sed -i doc/Makefile \
+ -e "s/ latexusage.pdf//g" \
+ -e "s/pdflatex latexusage//g" \
+ -e "s/ asymptote.pdf//g" \
+ -e "/pdflatex CAD/d" \
+ -e "s/CAD.pdf//" \
+ -e "s/TeXShopAndAsymptote.pdf//"
+fi
+
make
make check
make install DESTDIR=$PKG
-rm -rf $PKG/usr/info/asymptote
mkdir -p $PKG/usr/share/vim/vimfiles/syntax
mv $PKG/usr/share/texmf-dist/asymptote/*.vim $PKG/usr/share/vim/vimfiles/syntax
(
@@ -119,15 +131,18 @@ find $PKG/usr/man -type f -exec gzip -9 {} +
for links in $(find $PKG/usr/man -type l ) ; do ln -sf $( readlink $links ).gz $links.gz;rm $links;done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv BUGS ChangeLog INSTALL LICENSE LICENSE.LESSER README TODO \
+mv BUGS ChangeLog LICENSE LICENSE.LESSER README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cd $PKG/usr/info
-find . -type f -exec gzip -9 {} +
-for links in $(find . -type l ) ; do ln -sf $( readlink $links ).gz $links.gz;rm $links;done
+mv $PKG/usr/info/asymptote/asymptote.info $PKG/usr/info/
+rmdir $PKG/usr/info/asymptote
+find $PKG/usr/info -name '*.info*' -type f -exec gzip -9 {} +
mkdir $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/douninst.sh > $PKG/install/douninst.sh
+
cd $PKG
/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/asymptote/asymptote.info b/office/asymptote/asymptote.info
index 1a9aed22d3..4aba737b80 100644
--- a/office/asymptote/asymptote.info
+++ b/office/asymptote/asymptote.info
@@ -1,10 +1,10 @@
PRGNAM="asymptote"
-VERSION="2.70"
+VERSION="2.88"
HOMEPAGE="https://asymptote.sourceforge.io/"
-DOWNLOAD="https://downloads.sourceforge.net/asymptote/asymptote-2.70.src.tgz"
-MD5SUM="b57e685568a7cca69024a86c7276eb6d"
+DOWNLOAD="https://downloads.sourceforge.net/asymptote/asymptote-2.88.src.tgz"
+MD5SUM="57c7effe845eb624f48a6cc750aaa302"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="glm"
MAINTAINER="Johannes Schoepfer"
-EMAIL="slackbuilds at schoepfer dot info"
+EMAIL="slackbuilds@schoepfer.info"
diff --git a/office/asymptote/doinst.sh b/office/asymptote/doinst.sh
new file mode 100644
index 0000000000..86b8ef5149
--- /dev/null
+++ b/office/asymptote/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/install-info ]; then
+ /usr/bin/install-info --info-dir=usr/info usr/info/PRGNAM.info.gz 2> /dev/null
+fi
diff --git a/office/asymptote/douninst.sh b/office/asymptote/douninst.sh
new file mode 100644
index 0000000000..1bef502028
--- /dev/null
+++ b/office/asymptote/douninst.sh
@@ -0,0 +1,6 @@
+if [ -x /usr/bin/install-info -a -d usr/info ]; then
+ ( cd usr/info
+ rm -f dir
+ for i in *.info*; do /usr/bin/install-info $i dir 2>/dev/null; done
+ )
+fi