summaryrefslogtreecommitdiffstats
path: root/office/TaskCoach
diff options
context:
space:
mode:
Diffstat (limited to 'office/TaskCoach')
-rw-r--r--office/TaskCoach/README4
-rw-r--r--office/TaskCoach/TaskCoach.SlackBuild102
-rw-r--r--office/TaskCoach/TaskCoach.desktop8
-rw-r--r--office/TaskCoach/TaskCoach.info10
-rw-r--r--office/TaskCoach/doinst.sh3
-rw-r--r--office/TaskCoach/slack-desc19
6 files changed, 0 insertions, 146 deletions
diff --git a/office/TaskCoach/README b/office/TaskCoach/README
deleted file mode 100644
index ca1e26e38b..0000000000
--- a/office/TaskCoach/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Task Coach is a simple open source todo manager to keep track
-of personal tasks and todo lists. It is designed for composite
-tasks, and also offers effort tracking, categories, notes and
-more.
diff --git a/office/TaskCoach/TaskCoach.SlackBuild b/office/TaskCoach/TaskCoach.SlackBuild
deleted file mode 100644
index 1d712a475f..0000000000
--- a/office/TaskCoach/TaskCoach.SlackBuild
+++ /dev/null
@@ -1,102 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for TaskCoach
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=TaskCoach
-VERSION=${VERSION:-1.4.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/share/applications
-install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-
-mkdir -p $PKG/usr/share/pixmaps/
-install -D -m644 icons.in/${PRGNAM,,}.png $PKG/usr/share/pixmaps/${PRGNAM,,}.png
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/TaskCoach/TaskCoach.desktop b/office/TaskCoach/TaskCoach.desktop
deleted file mode 100644
index e8502c238c..0000000000
--- a/office/TaskCoach/TaskCoach.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=Task Coach
-Comment= Your friendly task manager
-Exec=taskcoach.py
-Icon=taskcoach
-Terminal=false
-Type=Application
-Categories=Office;
diff --git a/office/TaskCoach/TaskCoach.info b/office/TaskCoach/TaskCoach.info
deleted file mode 100644
index a02a957507..0000000000
--- a/office/TaskCoach/TaskCoach.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="TaskCoach"
-VERSION="1.4.3"
-HOMEPAGE="http://taskcoach.org/"
-DOWNLOAD="http://downloads.sourceforge.net/taskcoach/TaskCoach-1.4.3.tar.gz"
-MD5SUM="10c145061ea72b9ecbb9e276cc3ef10c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="wxPython python2-twisted"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/office/TaskCoach/doinst.sh b/office/TaskCoach/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/office/TaskCoach/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/office/TaskCoach/slack-desc b/office/TaskCoach/slack-desc
deleted file mode 100644
index 3fd957ac7d..0000000000
--- a/office/TaskCoach/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-TaskCoach: TaskCoach (Task Manager)
-TaskCoach:
-TaskCoach: Task Coach is a simple open source todo manager to keep track
-TaskCoach: of personal tasks and todo lists. It is designed for composite
-TaskCoach: tasks, and also offers effort tracking, categories, notes and more.
-TaskCoach:
-TaskCoach: Homepage: http://taskcoach.org/
-TaskCoach:
-TaskCoach:
-TaskCoach:
-TaskCoach: