summaryrefslogtreecommitdiffstats
path: root/network/cherokee/cherokee.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/cherokee/cherokee.SlackBuild')
-rw-r--r--network/cherokee/cherokee.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/network/cherokee/cherokee.SlackBuild b/network/cherokee/cherokee.SlackBuild
index b0eff407bc..207850d16f 100644
--- a/network/cherokee/cherokee.SlackBuild
+++ b/network/cherokee/cherokee.SlackBuild
@@ -7,8 +7,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cherokee
-VERSION=${VERSION:-20180709_9a75e65}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-20230111_ce1ca8a}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -96,6 +96,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s|\[2\.71|[2.69|" configure.ac m4/{nls,po,progtest}.m4
+
# Apply all the patches in $CWD/patches (thanks Gentoo)
for patch in $CWD/patches/* ; do
patch -p1 < $patch
@@ -117,7 +119,7 @@ CXXFLAGS="$SLKCFLAGS" \
--with-mysql=$MYSQL \
--enable-ipv6=$IPV6 \
--enable-admin=$ADMIN \
- --disable-pam \
+ --enable-pam \
--disable-static \
--enable-trace=$TRACE