summaryrefslogtreecommitdiffstats
path: root/libraries/python3-rpyc
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/python3-rpyc')
-rw-r--r--libraries/python3-rpyc/python3-rpyc.SlackBuild33
-rw-r--r--libraries/python3-rpyc/python3-rpyc.info6
2 files changed, 13 insertions, 26 deletions
diff --git a/libraries/python3-rpyc/python3-rpyc.SlackBuild b/libraries/python3-rpyc/python3-rpyc.SlackBuild
index 55cc970a89..b10b856c57 100644
--- a/libraries/python3-rpyc/python3-rpyc.SlackBuild
+++ b/libraries/python3-rpyc/python3-rpyc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-rpyc
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -23,11 +23,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220919 46and2: Updated version, added DEPS.
+# -build process changed
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-rpyc
-SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-5.1.0}
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-6.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +52,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,11 +63,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/python3-rpyc/python3-rpyc.info b/libraries/python3-rpyc/python3-rpyc.info
index ca3b1e44e9..333d3a01d3 100644
--- a/libraries/python3-rpyc/python3-rpyc.info
+++ b/libraries/python3-rpyc/python3-rpyc.info
@@ -1,8 +1,8 @@
PRGNAM="python3-rpyc"
-VERSION="5.1.0"
+VERSION="6.0.0"
HOMEPAGE="http://rpyc.readthedocs.org/en/latest/"
-DOWNLOAD="https://github.com/tomerfiliba-org/rpyc/archive/refs/tags/5.1.0/rpyc-5.1.0.tar.gz"
-MD5SUM="9ccb364d31069dc7fe441ac0f83848c7"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/r/rpyc/rpyc-6.0.0.tar.gz"
+MD5SUM="a18c605c4b739828af9645c80e37eec6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-plumbum"