summaryrefslogtreecommitdiffstats
path: root/graphics/digikam
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/digikam')
-rw-r--r--graphics/digikam/README14
-rw-r--r--graphics/digikam/digikam.SlackBuild116
-rw-r--r--graphics/digikam/digikam.info10
-rw-r--r--graphics/digikam/doinst.sh9
-rw-r--r--graphics/digikam/lensfun-0.3.2.patch26
-rw-r--r--graphics/digikam/libpgf.patch33
-rw-r--r--graphics/digikam/slack-desc19
7 files changed, 0 insertions, 227 deletions
diff --git a/graphics/digikam/README b/graphics/digikam/README
deleted file mode 100644
index a002764d17..0000000000
--- a/graphics/digikam/README
+++ /dev/null
@@ -1,14 +0,0 @@
-digiKam is a simple digital photo management application for KDE,
-which makes importing and organizing digital photos a "snap". The
-photos can be organized in albums which can be sorted chronologically,
-by directory layout or by custom collections. An easy to use interface
-is provided that enables you to connect to your camera and preview,
-download and/or delete your images.
-
-enblend-enfuse, hugin, sqlite2, and libdc1394 are optional dependencies.
-
-NOTES:
-- digikam now ships with its own internal version of kipi-plugins.
-- please remove previous version before building the current version.
-- Make sure qt5 is not installed before building opencv or else digiKam
- will segfault.
diff --git a/graphics/digikam/digikam.SlackBuild b/graphics/digikam/digikam.SlackBuild
deleted file mode 100644
index dd492bcb28..0000000000
--- a/graphics/digikam/digikam.SlackBuild
+++ /dev/null
@@ -1,116 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for digiKam
-
-# Copyright 2007-2011 Frank Caraballo <fecaraballo{at}gmail{dot}com>
-# Copyright 2013-2019 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=digikam
-VERSION=${VERSION:-4.14.0}
-BUILD=${BUILD:-4}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-else
- SLKCFLAGS="-O2"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-cd core
-# patch for lensfun 0.3.2
-patch -p1 < $CWD/lensfun-0.3.2.patch
-
-# workaround for flex-2.6.0
-sed -e '/fno-tree-pre/d' -i CMakeLists.txt
-cd ..
-
-patch -p0 < $CWD/libpgf.patch
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=$(kde4-config --libsuffix) \
- -DMAN_INSTALL_DIR=/usr/man \
- -DSYSCONF_INSTALL_DIR=/etc/kde \
- -DCMAKE_VERBOSE_MAKEFILE:BOOL="TRUE" \
- -DDIGIKAMSC_COMPILE_LIBMEDIAWIKI=ON \
- -DDIGIKAMSC_COMPILE_LIBKVKONTAKTE=ON \
- -DDIGIKAMSC_COMPILE_LIBKFACE=ON \
- -DDIGIKAMSC_COMPILE_DOC=OFF \
- -DCMAKE_CXX_FLAGS:STRING="$(/usr/bin/Magick++-config --libs)" \
- -DENABLE_OPENCV3=ON \
- -DCMAKE_C_COMPILER=clang \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING* NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/digikam/digikam.info b/graphics/digikam/digikam.info
deleted file mode 100644
index 3e6158f3c8..0000000000
--- a/graphics/digikam/digikam.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="digikam"
-VERSION="4.14.0"
-HOMEPAGE="https://www.digikam.org/"
-DOWNLOAD="https://download.kde.org/Attic/digikam/digikam-4.14.0.tar.bz2"
-MD5SUM="8fd3cb0a822e8c2d4102e8adc00c082f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="liblqr lensfun ffmpeg libpgf libkvkontakte libkface libkgeomap4"
-MAINTAINER="Willy Sudiarto Raharjo"
-EMAIL="willysr@slackbuilds.org"
diff --git a/graphics/digikam/doinst.sh b/graphics/digikam/doinst.sh
deleted file mode 100644
index 7ffea19638..0000000000
--- a/graphics/digikam/doinst.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications/kde4 >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/graphics/digikam/lensfun-0.3.2.patch b/graphics/digikam/lensfun-0.3.2.patch
deleted file mode 100644
index 37776f6e31..0000000000
--- a/graphics/digikam/lensfun-0.3.2.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Gilles Caulier <caulier.gilles@gmail.com>
-Date: Mon, 14 Dec 2015 21:41:55 +0000
-Subject: fix compilation with Lensfun 0.3.2
-X-Git-Url: http://quickgit.kde.org/?p=digikam.git&a=commitdiff&h=0f159981176faa6da701f112bfe557b79804d468
----
-fix compilation with Lensfun 0.3.2
-It still compatible with older lensfun releases.
-BUGS: 356672
-FIXED-IN: 5.0.0
----
-
-
---- a/libs/dimg/filters/lens/lensfuniface.h
-+++ b/libs/dimg/filters/lens/lensfuniface.h
-@@ -24,10 +24,7 @@
-
- // Lib LensFun includes
-
--extern "C"
--{
- #include <lensfun.h>
--}
-
- // Local includes
-
-
diff --git a/graphics/digikam/libpgf.patch b/graphics/digikam/libpgf.patch
deleted file mode 100644
index 5d2e7498bb..0000000000
--- a/graphics/digikam/libpgf.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- core/libs/dimg/loaders/pgfloader.cpp.orig 2019-03-17 16:52:40.102888509 +0700
-+++ core/libs/dimg/loaders/pgfloader.cpp 2019-03-17 16:52:51.404020146 +0700
-@@ -442,14 +442,6 @@
- }
- }
-
--#ifdef PGFCodecVersionID
--# if PGFCodecVersionID < 0x061142
-- header.background.rgbtBlue = 0;
-- header.background.rgbtGreen = 0;
-- header.background.rgbtRed = 0;
--# endif
--#endif
--
- pgf.SetHeader(header);
-
- // NOTE: see bug #273765 : Loading PGF thumbs with OpenMP support through a separated thread do not work properlly with libppgf 6.11.24
---- core/libs/threadimageio/pgfutils.cpp.orig 2019-03-17 17:07:35.586244318 +0700
-+++ core/libs/threadimageio/pgfutils.cpp 2019-03-17 17:07:47.110376670 +0700
-@@ -262,13 +262,6 @@
- header.mode = ImageModeRGBA;
- header.usedBitsPerChannel = 0; // Auto
-
--#ifdef PGFCodecVersionID
--# if PGFCodecVersionID < 0x061142
-- header.background.rgbtBlue = 0;
-- header.background.rgbtGreen = 0;
-- header.background.rgbtRed = 0;
--# endif
--#endif
- pgfImg.SetHeader(header);
-
- // NOTE: see bug #273765 : Loading PGF thumbs with OpenMP support through a separated thread do not work properlly with libppgf 6.11.24
diff --git a/graphics/digikam/slack-desc b/graphics/digikam/slack-desc
deleted file mode 100644
index cf90391876..0000000000
--- a/graphics/digikam/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-digikam: digikam (KDE Photo Management Application)
-digikam:
-digikam: digiKam is a simple digital photo management application for KDE,
-digikam: which makes importing and organizing digital photos a "snap". The
-digikam: photos can be organized in albums which can be sorted chronologically,
-digikam: by directory layout or by custom collections. An easy to use interface
-digikam: is provided that enables you to connect to your camera and preview,
-digikam: download and/or delete your images.
-digikam:
-digikam: Homepage: http://www.digikam.org/
-digikam: