summaryrefslogtreecommitdiffstats
path: root/gis/python3-cftime
diff options
context:
space:
mode:
Diffstat (limited to 'gis/python3-cftime')
-rw-r--r--gis/python3-cftime/README4
-rw-r--r--gis/python3-cftime/python3-cftime.SlackBuild84
-rw-r--r--gis/python3-cftime/python3-cftime.info10
-rw-r--r--gis/python3-cftime/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/gis/python3-cftime/README b/gis/python3-cftime/README
new file mode 100644
index 0000000000..80a804fee4
--- /dev/null
+++ b/gis/python3-cftime/README
@@ -0,0 +1,4 @@
+python3-cftime
+
+Python library for decoding time units and variable values in a netCDF
+file conforming to the Climate and Forecasting (CF) netCDF conventions.
diff --git a/gis/python3-cftime/python3-cftime.SlackBuild b/gis/python3-cftime/python3-cftime.SlackBuild
new file mode 100644
index 0000000000..91ccad5961
--- /dev/null
+++ b/gis/python3-cftime/python3-cftime.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/bash
+
+# Slackware build script for python3-cftime
+
+# Copyright 2022-2023 - Gregory J. L. Tourte <artourter@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-cftime
+VERSION=${VERSION:-1.6.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=cftime
+SRCVER=${VERSION}rel
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ Changelog LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/python3-cftime/python3-cftime.info b/gis/python3-cftime/python3-cftime.info
new file mode 100644
index 0000000000..6f074ce474
--- /dev/null
+++ b/gis/python3-cftime/python3-cftime.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-cftime"
+VERSION="1.6.3"
+HOMEPAGE="https://unidata.github.io/cftime/"
+DOWNLOAD="https://github.com/Unidata/cftime/archive/v1.6.3rel/cftime-1.6.3rel.tar.gz"
+MD5SUM="2e77ad0b187fbdcd48fd1f39eecfa04a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-numpy"
+MAINTAINER="ArTourter"
+EMAIL="artourter@gmail.com"
diff --git a/gis/python3-cftime/slack-desc b/gis/python3-cftime/slack-desc
new file mode 100644
index 0000000000..993e08f765
--- /dev/null
+++ b/gis/python3-cftime/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-cftime: python3-cftime (Time-handling functionality from netcdf4)
+python3-cftime:
+python3-cftime: Python library for decoding time units and variable values in a netCDF
+python3-cftime: file conforming to the Climate and Forecasting (CF) netCDF
+python3-cftime: conventions.
+python3-cftime:
+python3-cftime:
+python3-cftime:
+python3-cftime:
+python3-cftime:
+python3-cftime: