summaryrefslogtreecommitdiffstats
path: root/development/gr-osmosdr
diff options
context:
space:
mode:
Diffstat (limited to 'development/gr-osmosdr')
-rw-r--r--development/gr-osmosdr/boost-1.73.patch20
-rw-r--r--development/gr-osmosdr/gr-osmosdr.SlackBuild3
2 files changed, 23 insertions, 0 deletions
diff --git a/development/gr-osmosdr/boost-1.73.patch b/development/gr-osmosdr/boost-1.73.patch
new file mode 100644
index 0000000000..60d26518be
--- /dev/null
+++ b/development/gr-osmosdr/boost-1.73.patch
@@ -0,0 +1,20 @@
+diff -Naur gr-osmosdr-20170612.orig/lib/rfspace/rfspace_source_c.cc gr-osmosdr-20170612/lib/rfspace/rfspace_source_c.cc
+--- gr-osmosdr-20170612.orig/lib/rfspace/rfspace_source_c.cc 2018-06-14 21:01:32.000000000 +0200
++++ gr-osmosdr-20170612/lib/rfspace/rfspace_source_c.cc 2020-05-17 15:11:25.958538000 +0200
+@@ -1089,14 +1089,14 @@
+ // Start the asynchronous receive operation. The handle_receive function
+ // used as a callback will update the ec and rx_bytes variables.
+ socket.async_receive( boost::asio::buffer(data, sizeof(data)),
+- boost::bind(handle_receive, _1, _2, &ec, &rx_bytes) );
++ boost::bind(handle_receive, boost::placeholders::_1, boost::placeholders::_2, &ec, &rx_bytes) );
+
+ // Set a deadline for the asynchronous operation.
+ timer.expires_from_now( boost::posix_time::milliseconds(10) );
+
+ // Start an asynchronous wait on the timer. The handle_timer function
+ // used as a callback will update the ec variable.
+- timer.async_wait( boost::bind(handle_timer, _1, &ec) );
++ timer.async_wait( boost::bind(handle_timer, boost::placeholders::_1, &ec) );
+
+ // Reset the io_service in preparation for a subsequent run_one() invocation.
+ ios.reset();
diff --git a/development/gr-osmosdr/gr-osmosdr.SlackBuild b/development/gr-osmosdr/gr-osmosdr.SlackBuild
index 8ec9fc13df..7831a9de81 100644
--- a/development/gr-osmosdr/gr-osmosdr.SlackBuild
+++ b/development/gr-osmosdr/gr-osmosdr.SlackBuild
@@ -70,6 +70,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s|gr_osmosdr_libs}|gr_osmosdr_libs} -lboost_chrono|" lib/CMakeLists.txt
+patch -p1 < $CWD/boost-1.73.patch
+
mkdir -p build
cd build
cmake \