summaryrefslogtreecommitdiffstats
path: root/development/codespell/codespell.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/codespell/codespell.SlackBuild')
-rw-r--r--development/codespell/codespell.SlackBuild42
1 files changed, 21 insertions, 21 deletions
diff --git a/development/codespell/codespell.SlackBuild b/development/codespell/codespell.SlackBuild
index b74e7036bf..74ec393dc3 100644
--- a/development/codespell/codespell.SlackBuild
+++ b/development/codespell/codespell.SlackBuild
@@ -6,6 +6,12 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230820 bkw: update for 2.2.5, *many* thanks to fourtysixandtwo for
+# his python3-setuptools-opt build, and for figuring out the bug in
+# this build's pyproject.toml.
+
+# 20230115 bkw: update for 2.2.1, not the latest (see README).
+
# 20210829 bkw:
# - update for 2.1.0.
# - use python3 by default. add PYVER var to force building with 2,
@@ -15,7 +21,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=codespell
-VERSION=${VERSION:-2.1.0}
+VERSION=${VERSION:-2.2.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -37,20 +43,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -60,17 +52,25 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+# write_to directive is broken, turns out we can do without it.
+sed -i '/^write_to/d' pyproject.toml
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
-python${PYVER:-3} setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
-make $PRGNAM.1
+# upstream removed the man page. including a copy of the 2.1.0 man page,
+# which seems to still apply to 2.2.1 (all the options are the same).
mkdir -p $PKG/usr/man/man1
-gzip -9c < $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* COPYING example $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install