summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
Diffstat (limited to 'desktop')
-rw-r--r--desktop/openbox/openbox.SlackBuild2
-rw-r--r--desktop/openbox/patches/917204_undecorated_maximized_no_border.patch22
-rw-r--r--desktop/openbox/patches/9ed6fdd71890c5cc43747f105382d5677e5d37e7.patch50
-rw-r--r--desktop/openbox/patches/debian-887908.patch31
-rw-r--r--desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.SlackBuild2
-rw-r--r--desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.info6
-rw-r--r--desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.SlackBuild2
-rw-r--r--desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.info6
-rw-r--r--desktop/xfce4-volumed-pulse/xfce4-volumed-pulse.SlackBuild2
9 files changed, 115 insertions, 8 deletions
diff --git a/desktop/openbox/openbox.SlackBuild b/desktop/openbox/openbox.SlackBuild
index 36d3f279e6..80501d9f46 100644
--- a/desktop/openbox/openbox.SlackBuild
+++ b/desktop/openbox/openbox.SlackBuild
@@ -102,6 +102,8 @@ find -L . \
# Convert openbox-xdg-autostart from python2 to python3
patch -p1 < $CWD/py2-to-py3.patch
+for i in $CWD/patches/* ; do patch -p1 < $i ; done
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/desktop/openbox/patches/917204_undecorated_maximized_no_border.patch b/desktop/openbox/patches/917204_undecorated_maximized_no_border.patch
new file mode 100644
index 0000000000..915cc1ea9a
--- /dev/null
+++ b/desktop/openbox/patches/917204_undecorated_maximized_no_border.patch
@@ -0,0 +1,22 @@
+Description: Removed top border on undecorated maximized windows
+Author: Valentin Blot <debian-devel@valentinblot.org>
+Origin: other
+Bug-Debian: https://bugs.debian.org/917204
+Forwarded: no
+Last-Update: 2018-12-23
+
+--- a/openbox/frame.c
++++ b/openbox/frame.c
+@@ -585,12 +585,6 @@ void frame_adjust_area(ObFrame *self, gb
+
+ if (self->decorations & OB_FRAME_DECOR_TITLEBAR)
+ self->size.top += ob_rr_theme->title_height + self->bwidth;
+- else if (self->max_horz && self->max_vert) {
+- /* A maximized and undecorated window needs a border on the
+- top of the window to let the user still undecorate/unmaximize the
+- window via the client menu. */
+- self->size.top += self->bwidth;
+- }
+
+ if (self->decorations & OB_FRAME_DECOR_HANDLE &&
+ ob_rr_theme->handle_height > 0)
diff --git a/desktop/openbox/patches/9ed6fdd71890c5cc43747f105382d5677e5d37e7.patch b/desktop/openbox/patches/9ed6fdd71890c5cc43747f105382d5677e5d37e7.patch
new file mode 100644
index 0000000000..ef68d31213
--- /dev/null
+++ b/desktop/openbox/patches/9ed6fdd71890c5cc43747f105382d5677e5d37e7.patch
@@ -0,0 +1,50 @@
+From 9ed6fdd71890c5cc43747f105382d5677e5d37e7 Mon Sep 17 00:00:00 2001
+From: pldubouilh <pldubouilh@gmail.com>
+Date: Fri, 17 Mar 2023 18:23:47 +0100
+Subject: [PATCH] Fix list traversal issue in client_calc_layer
+
+The calls to client_calc_layer_internal can modify stacking_list, which
+can cause us to follow dangling ->next pointers (either by the pointer
+itself already being freed, or it pointing to a freed area). Avoid this
+by copying the list first, the goal is to visit every client in the list
+once so this should be fine.
+---
+ openbox/client.c | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/openbox/client.c b/openbox/client.c
+index 7168b2407..b8264587c 100644
+--- a/openbox/client.c
++++ b/openbox/client.c
+@@ -2742,9 +2742,12 @@ static void client_calc_layer_internal(ObClient *self)
+ void client_calc_layer(ObClient *self)
+ {
+ GList *it;
++ /* the client_calc_layer_internal calls below modify stacking_list,
++ so we have to make a copy to iterate over */
++ GList *list = g_list_copy(stacking_list);
+
+ /* skip over stuff above fullscreen layer */
+- for (it = stacking_list; it; it = g_list_next(it))
++ for (it = list; it; it = g_list_next(it))
+ if (window_layer(it->data) <= OB_STACKING_LAYER_FULLSCREEN) break;
+
+ /* find the windows in the fullscreen layer, and mark them not-visited */
+@@ -2757,7 +2760,7 @@ void client_calc_layer(ObClient *self)
+ client_calc_layer_internal(self);
+
+ /* skip over stuff above fullscreen layer */
+- for (it = stacking_list; it; it = g_list_next(it))
++ for (it = list; it; it = g_list_next(it))
+ if (window_layer(it->data) <= OB_STACKING_LAYER_FULLSCREEN) break;
+
+ /* now recalc any windows in the fullscreen layer which have not
+@@ -2768,6 +2771,8 @@ void client_calc_layer(ObClient *self)
+ !WINDOW_AS_CLIENT(it->data)->visited)
+ client_calc_layer_internal(it->data);
+ }
++
++ g_list_free(it);
+ }
+
+ gboolean client_should_show(ObClient *self)
diff --git a/desktop/openbox/patches/debian-887908.patch b/desktop/openbox/patches/debian-887908.patch
new file mode 100644
index 0000000000..2c8794ed7f
--- /dev/null
+++ b/desktop/openbox/patches/debian-887908.patch
@@ -0,0 +1,31 @@
+Description: Fix toggled hover and pressed images masks not loaded
+Author: "E. Serradilla" <eserradi@gmx.com>
+Debian-Bugs: https://bugs.debian.org/887908
+
+--- a/obrender/theme.c
++++ b/obrender/theme.c
+@@ -1494,8 +1494,10 @@ static void read_button_styles(XrmDataba
+ READ_BUTTON_MASK_COPY(disabled, btn->unpressed_mask);
+ READ_BUTTON_MASK_COPY(hover, btn->unpressed_mask);
+ if (toggled_mask) {
+- READ_BUTTON_MASK_COPY(pressed_toggled, btn->unpressed_toggled_mask);
+- READ_BUTTON_MASK_COPY(hover_toggled, btn->unpressed_toggled_mask);
++ g_snprintf(name, 128, "%s_toggled_pressed.xbm", btnname);
++ READ_MASK_COPY(name, btn->pressed_toggled_mask, btn->unpressed_toggled_mask);
++ g_snprintf(name, 128, "%s_toggled_hover.xbm", btnname);
++ READ_MASK_COPY(name, btn->hover_toggled_mask, btn->unpressed_toggled_mask);
+ }
+
+ #define READ_BUTTON_APPEARANCE(typedots, type, fallback) \
+@@ -1532,8 +1534,8 @@ static void read_button_styles(XrmDataba
+ READ_BUTTON_APPEARANCE("disabled", disabled, 0);
+ READ_BUTTON_APPEARANCE("hover", hover, 0);
+ if (toggled_mask) {
+- READ_BUTTON_APPEARANCE("unpressed.toggled", unpressed_toggled, 1);
+- READ_BUTTON_APPEARANCE("pressed.toggled", pressed_toggled, 0);
+- READ_BUTTON_APPEARANCE("hover.toggled", hover_toggled, 0);
++ READ_BUTTON_APPEARANCE("toggled.unpressed", unpressed_toggled, 1);
++ READ_BUTTON_APPEARANCE("toggled.pressed", pressed_toggled, 0);
++ READ_BUTTON_APPEARANCE("toggled.hover", hover_toggled, 0);
+ }
+ }
diff --git a/desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.SlackBuild b/desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.SlackBuild
index f075e52868..b2484290c4 100644
--- a/desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.SlackBuild
+++ b/desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.SlackBuild
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xfce4-cpugraph-plugin
-VERSION=${VERSION:-1.2.6}
+VERSION=${VERSION:-1.2.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
diff --git a/desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.info b/desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.info
index e12ac4a63b..a0837ac60c 100644
--- a/desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.info
+++ b/desktop/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin.info
@@ -1,8 +1,8 @@
PRGNAM="xfce4-cpugraph-plugin"
-VERSION="1.2.6"
+VERSION="1.2.7"
HOMEPAGE="https://goodies.xfce.org/"
-DOWNLOAD="https://archive.xfce.org/src/panel-plugins/xfce4-cpugraph-plugin/1.2/xfce4-cpugraph-plugin-1.2.6.tar.bz2"
-MD5SUM="5598a55557cd03583b1867432dc51039"
+DOWNLOAD="https://archive.xfce.org/src/panel-plugins/xfce4-cpugraph-plugin/1.2/xfce4-cpugraph-plugin-1.2.7.tar.bz2"
+MD5SUM="0480611899650e2d4304d13e0e0dda77"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.SlackBuild b/desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.SlackBuild
index 9486471dbb..260088327d 100644
--- a/desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.SlackBuild
+++ b/desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xfce4-sensors-plugin
-VERSION=${VERSION:-1.4.3}
+VERSION=${VERSION:-1.4.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
diff --git a/desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.info b/desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.info
index 67196fa56a..d3d9fb0eb8 100644
--- a/desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.info
+++ b/desktop/xfce4-sensors-plugin/xfce4-sensors-plugin.info
@@ -1,8 +1,8 @@
PRGNAM="xfce4-sensors-plugin"
-VERSION="1.4.3"
+VERSION="1.4.4"
HOMEPAGE="https://docs.xfce.org/panel-plugins/xfce4-sensors-plugin/start"
-DOWNLOAD="https://archive.xfce.org/src/panel-plugins/xfce4-sensors-plugin/1.4/xfce4-sensors-plugin-1.4.3.tar.bz2"
-MD5SUM="e55dfea49b0c5e9edf068db3b8398240"
+DOWNLOAD="https://archive.xfce.org/src/panel-plugins/xfce4-sensors-plugin/1.4/xfce4-sensors-plugin-1.4.4.tar.bz2"
+MD5SUM="0684f0f86e2edfb306086445478f7bbd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/desktop/xfce4-volumed-pulse/xfce4-volumed-pulse.SlackBuild b/desktop/xfce4-volumed-pulse/xfce4-volumed-pulse.SlackBuild
index 3f7a010194..e4644a9955 100644
--- a/desktop/xfce4-volumed-pulse/xfce4-volumed-pulse.SlackBuild
+++ b/desktop/xfce4-volumed-pulse/xfce4-volumed-pulse.SlackBuild
@@ -79,6 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i -e "s|XDT_CHECK_PACKAGE(\[GLIB\], \[glib-2.0\], \[2.16\])|XDT_CHECK_PACKAGE(\[GLIB\], \[glib-2.0\], \[2.26\])|" configure.ac.in
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./autogen.sh \