summaryrefslogtreecommitdiffstats
path: root/audio/plug
diff options
context:
space:
mode:
Diffstat (limited to 'audio/plug')
-rw-r--r--audio/plug/CMakeLists.txt.patch11
-rw-r--r--audio/plug/README19
-rw-r--r--audio/plug/doinst.sh13
-rw-r--r--audio/plug/plug.SlackBuild115
-rw-r--r--audio/plug/plug.desktop9
-rw-r--r--audio/plug/plug.info10
-rw-r--r--audio/plug/plug.pngbin0 -> 98946 bytes
-rw-r--r--audio/plug/slack-desc19
8 files changed, 196 insertions, 0 deletions
diff --git a/audio/plug/CMakeLists.txt.patch b/audio/plug/CMakeLists.txt.patch
new file mode 100644
index 0000000000..5be4e0e60e
--- /dev/null
+++ b/audio/plug/CMakeLists.txt.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt 2023-12-03 14:22:05.000000000 +0000
++++ CMakeLists.txt.new 2023-12-04 22:05:56.210467471 +0000
+@@ -4,7 +4,7 @@
+ message(STATUS "~~~ ${PROJECT_NAME} v${PROJECT_VERSION} ~~~")
+
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+-option(PLUG_UNITTEST "Build Unit Tests" ON)
++option(PLUG_UNITTEST "Build Unit Tests" OFF)
+ message(STATUS "Unit Tests : ${PLUG_UNITTEST}")
+
+ option(PLUG_COVERAGE "Enable Coverage" OFF)
diff --git a/audio/plug/README b/audio/plug/README
new file mode 100644
index 0000000000..83d87e18a0
--- /dev/null
+++ b/audio/plug/README
@@ -0,0 +1,19 @@
+Plug ( Fender Mustang Amps Controller )
+
+Plug is a Software to control Fender Mustang Amps, a linux
+replacement for the now discontinued Fender Fuse, for example.
+
+It addresses the following models:
+
+v1: Mustang I, Mustang II, Mustang III, Mustang IV, Mustang V,
+ Mustang Bronco, Mustang Mini and Mustang Floor.
+
+v2: Mustang I, Mustang II, Mustang III, Mustang IV and Mustang V.
+
+This installer installs the udev rule "50-mustang.rules".
+
+You need to manually add you user to the plugdev group using:
+
+ usermod -a -G plugdev "your-username"
+
+This requires the package gtest (available on Slackbuilds).
diff --git a/audio/plug/doinst.sh b/audio/plug/doinst.sh
new file mode 100644
index 0000000000..aea0f894eb
--- /dev/null
+++ b/audio/plug/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/audio/plug/plug.SlackBuild b/audio/plug/plug.SlackBuild
new file mode 100644
index 0000000000..b13b1b9254
--- /dev/null
+++ b/audio/plug/plug.SlackBuild
@@ -0,0 +1,115 @@
+#!/bin/bash
+
+# Slackware build script for plug
+
+# Copyright 2022-2023 Antonio Leal, Porto Salvo, Oeiras, Portugal
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=plug
+VERSION=${VERSION:-1.4.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+BUILDDIR=$TMP/$PRGNAM-$VERSION
+
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+rm -rf $PKG $BUILDDIR
+mkdir -p $TMP $PKG $OUTPUT $BUILDDIR
+cd $TMP
+tar xvfz $CWD/$PRGNAM-$VERSION.tar.gz
+cd $BUILDDIR
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch CMakeLists.txt $CWD/CMakeLists.txt.patch
+
+mkdir build
+cd build
+cmake ..
+make
+#make unittest
+
+mkdir -p $PKG/usr/bin
+cp $BUILDDIR/build/src/plug $PKG/usr/bin
+mkdir -p $PKG/lib/udev/rules.d
+cp $BUILDDIR/cmake/*.rules $PKG/lib/udev/rules.d
+mkdir -p $PKG/usr/share/pixmaps
+cp $CWD/plug.png $PKG/usr/share/pixmaps
+mkdir -p $PKG/usr/share/applications
+cp $CWD/plug.desktop $PKG/usr/share/applications
+
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+mkdir -p $PKG/usr/doc/plug-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/plug-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/plug/plug.desktop b/audio/plug/plug.desktop
new file mode 100644
index 0000000000..33db868d67
--- /dev/null
+++ b/audio/plug/plug.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=plug
+Comment=Fender Mustang Amps Controller
+Exec=/usr/bin/plug
+Icon=/usr/share/pixmaps/plug.png
+Terminal=false
+Type=Application
+Categories=System;
+
diff --git a/audio/plug/plug.info b/audio/plug/plug.info
new file mode 100644
index 0000000000..0fe67adca4
--- /dev/null
+++ b/audio/plug/plug.info
@@ -0,0 +1,10 @@
+PRGNAM="plug"
+VERSION="1.4.5"
+HOMEPAGE="https://github.com/offa/plug"
+DOWNLOAD="https://github.com/offa/plug/archive/v1.4.5/plug-1.4.5.tar.gz"
+MD5SUM="c86d1dc7f4c44a8247199eaf3b6c448b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Antonio Leal"
+EMAIL="antonioleal@yahoo.com"
diff --git a/audio/plug/plug.png b/audio/plug/plug.png
new file mode 100644
index 0000000000..6886bd81a7
--- /dev/null
+++ b/audio/plug/plug.png
Binary files differ
diff --git a/audio/plug/slack-desc b/audio/plug/slack-desc
new file mode 100644
index 0000000000..68c4e128e1
--- /dev/null
+++ b/audio/plug/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+plug: plug ( Fender Mustang Amps Controller )
+plug:
+plug: Plug is a Software to control Fender Mustang Amps, a linux
+plug: replacement for the now discontinued Fender Fuse.
+plug: It addresses the following models:
+plug: v1: Mustang I, Mustang II, Mustang III, Mustang IV, Mustang V,
+plug: Mustang Bronco, Mustang Mini and Mustang Floor.
+plug: v2: Mustang I, Mustang II, Mustang III, Mustang IV and Mustang V.
+plug: You must add your user to the plugdev group before using
+plug: the program.
+plug: This program also requires the gtest package.