summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/ppsspp/ppsspp.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/ppsspp/ppsspp.SlackBuild b/games/ppsspp/ppsspp.SlackBuild
index cda92afb6c..7282983268 100644
--- a/games/ppsspp/ppsspp.SlackBuild
+++ b/games/ppsspp/ppsspp.SlackBuild
@@ -87,6 +87,10 @@ sed -i -e '/include(ccache)/d' CMakeLists.txt
# set git-version
sed -i "s/unknown/${VERSION}/" git-version.cmake
+# Build the internal ffmpeg (it's the only one supported by upstream)
+( cd ffmpeg
+ ./linux_x86-64.sh )
+
if [ "${QT:-OFF}" = "ON" ]; then
cmake -B build-qt \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
@@ -95,7 +99,6 @@ if [ "${QT:-OFF}" = "ON" ]; then
-DCMAKE_SKIP_RPATH=TRUE \
-DUSING_QT_UI=ON \
-DUSE_SYSTEM_LIBZIP=ON \
- -DUSE_SYSTEM_FFMPEG=ON \
-DUSE_DISCORD=OFF \
-DUSE_SYSTEM_ZSTD=ON \
-DCMAKE_BUILD_TYPE=Release
@@ -111,7 +114,6 @@ cmake -B build-sdl \
-DCMAKE_SKIP_RPATH=TRUE \
-DUSING_QT_UI=OFF \
-DUSE_SYSTEM_LIBZIP=ON \
- -DUSE_SYSTEM_FFMPEG=ON \
-DUSE_DISCORD=OFF \
-DUSE_SYSTEM_ZSTD=ON \
-DCMAKE_BUILD_TYPE=Release