summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Edinaldo P.Silva2024-02-22 15:34:32 +0100
committer Willy Sudiarto Raharjo2024-02-24 09:34:46 +0100
commitd6ef51ac455dc11e2a1b09b29e863371ec69ba77 (patch)
treea0b3b6aafa17006fa8c1e6ee356af7fce70decfd /system
parent04e41a837493ac73e4a96461dd899b8ca31be5f1 (diff)
downloadslackbuilds-d6ef51ac455dc11e2a1b09b29e863371ec69ba77.tar.gz
system/tilda: Updated for version 2.0.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/tilda/configure.ac212
-rw-r--r--system/tilda/tilda.195
-rw-r--r--system/tilda/tilda.SlackBuild8
-rw-r--r--system/tilda/tilda.info6
4 files changed, 218 insertions, 103 deletions
diff --git a/system/tilda/configure.ac b/system/tilda/configure.ac
new file mode 100644
index 0000000000..133336b7fd
--- /dev/null
+++ b/system/tilda/configure.ac
@@ -0,0 +1,212 @@
+dnl ****************************************************************************
+dnl Tilda autoconf configuration file.
+dnl Use autogen.sh to bootstrap the build system.
+dnl ****************************************************************************
+
+m4_define ([tilda_issues],
+ [https://github.com/lanoxx/tilda/issues])
+
+m4_define ([tilda_repository],
+ [https://github.com/lanoxx/tilda])
+
+AC_PREREQ([2.69])
+
+AC_INIT([Tilda],
+ [2.0.0],
+ [tilda_issues],
+ [tilda],
+ [tilda_repository])
+
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_SRCDIR([src/tilda.c])
+AC_CONFIG_HEADERS([config.h])
+
+AM_INIT_AUTOMAKE([foreign subdir-objects])
+
+# We are going to use silent builds which have a much
+# nicer output. More information can be found here:
+# https://wiki.gnome.org/Initiatives/GnomeGoals/NicerBuilds
+AM_SILENT_RULES([yes])
+
+# See http://www.gnu.org/savannah-checkouts/gnu/automake/manual/html_node/maintainer_002dmode.html
+# for an explanation of using this macro. The short explanation is:
+# AM_MAINTAINER_MODE is bad but
+# AM_MAINTAINER_MODE([enable]) is good
+AM_MAINTAINER_MODE([enable])
+
+# This registers the option '--enable-maintainer-flags' to the ./configure script
+# If this option is set then it activates both the '--enable-debug' and '--enable-debug-functions'
+# options that are defined below. It also activates several flags to the compile such that it
+# will show more warnings and errors to indicate problems in the source code.
+AC_ARG_ENABLE([maintainer-flags],
+ [AS_HELP_STRING([--enable-maintainer-flags],[\
+ Enables extra debugging; use this option if you want to develop for tilda,
+ but to not use it as an end user if you just want to compile and use tilda. \
+ This option includes the --enable-debug and --enable-debug-functions \
+ options. And sets several CFLAGS to enable more gcc warnings and errors.])])
+
+if test "x$enable_maintainer_flags" = "xyes"; then
+ enable_debug="yes"
+ enable_debug_functions="yes"
+ CFLAGS="$CFLAGS \
+ -Wall \
+ -Wextra \
+ -fno-common \
+ -Wstrict-aliasing=2 \
+ -Wshadow \
+ -Wmissing-prototypes \
+ -Wmissing-declarations \
+ -Wcast-align \
+ -Wuninitialized \
+ -Wno-strict-aliasing \
+ -Werror=pointer-arith \
+ -Werror=missing-declarations \
+ -Werror=redundant-decls \
+ -Werror=empty-body \
+ -Werror=format \
+ -Werror=format-security \
+ -Werror=format-nonliteral \
+ -Werror=init-self \
+ -Werror=vla \
+ -Wno-unused-parameter \
+ "
+fi
+
+# This registers the option '--enable-debug' in the ./configure script
+# If this option is set, then the the options -g and -ggdb will be
+# passed to the compiler.
+AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],[Enables extra debugging output and \
+ sets debug flags for gdb])])
+
+if test "x$enable_debug" = "xyes"; then
+ AC_DEFINE([DEBUG], [1], [Enable extra debugging output])
+ CFLAGS="$CFLAGS -g -ggdb"
+fi
+
+# This registers the option '--debug-functions' in the ./configure script
+# If this option is set, then the name of each entered function will be
+# printed on the shell.
+AC_ARG_ENABLE([debug-functions],
+ [AS_HELP_STRING([--enable-debug-functions],[Enables function call tracing. \
+ When this option is enabled tilda will print \
+ the name of each function that is called to the \
+ console.])])
+
+if test "x$enable_debug_functions" = "xyes"; then
+ AC_DEFINE([DEBUG_FUNCTIONS], [1], [Enable function call tracing])
+fi
+
+AC_ARG_ENABLE([clang],
+ [AS_HELP_STRING([--enable-clang],[use clang instead of gcc as C compiler.])])
+
+#Use C99 compilation mode
+if test "x$enable_clang" = "xyes"; then
+ # clang uses c99 mode by default, so we just set CC to clang and we are done
+ CC="clang";
+else
+ # We do not need to set CC as the default is gcc, but we need to set it to
+ # use C99 compilation mode
+ CFLAGS="$CFLAGS -std=c99";
+fi
+
+AC_ARG_ENABLE([lto],
+ [AS_HELP_STRING([--enable-lto],[Optimize at link time. This enables the compiler \
+ to do a better job at optimization and (hopefully) \
+ produce smaller binaries.])])
+
+if test "x$enable_lto" = "xyes"; then
+ CFLAGS="$CFLAGS -flto"
+ if test "$CC" != "clang"; then
+ # If the user has enabled lto explicitly, we assume he has made sure
+ # that his toolchain can indeed handle lto objects.
+ CFLAGS="$CFLAGS -fno-fat-lto-objects"
+ fi
+ # In the case of lto optimizations, we need to pass the optimization options
+ # to the linker as well as telling it to use the linker plugin.
+ LDFLAGS="$LDFLAGS $CFLAGS -fuse-linker-plugin"
+fi
+
+
+
+AC_PATH_PROG(GLIB_MKENUMS, glib-mkenums, no)
+if test x$GLIB_MKENUMS = xno; then
+ AC_MSG_ERROR(Could not find a glib-mkenums in your PATH)
+fi
+
+AC_PATH_PROG(GLIB_COMPILE_RESOURCES, glib-compile-resources, no)
+if test x$GLIB_COMPILE_RESOURCES = xno; then
+ AC_MSG_ERROR(Could not find a glib-compile-resources in your PATH)
+fi
+
+AC_PATH_PROG(GDBUS_CODEGEN, gdbus-codegen, no)
+if test x$GDBUS_CODEGEN = xno; then
+ AC_MSG_ERROR(Could not find a glib-codegen binary in your PATH)
+fi
+
+# Checks for programs.
+AC_PROG_CC
+AM_PROG_CC_C_O
+
+# This will initialize the internationalization
+# capabilities of glib (glib/gi18n.h) and gettext
+AM_GNU_GETTEXT_VERSION([0.18.1])
+AM_GNU_GETTEXT([external])
+# Checks for libraries.
+PKG_PROG_PKG_CONFIG
+PKG_CHECK_MODULES([GTK], [gtk+-3.0 >= 3.10.0])
+PKG_CHECK_MODULES([VTE], [vte-2.91 >= 0.40])
+PKG_CHECK_MODULES([LIBCONFUSE], [libconfuse])
+PKG_CHECK_MODULES([X11], [x11])
+
+# Checks for header files.
+AC_CHECK_HEADERS([fcntl.h malloc.h stdlib.h string.h strings.h sys/ioctl.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_STRTOD
+AC_CHECK_FUNCS([mkdir strcasecmp strchr strncasecmp strstr strtol])
+
+AC_CONFIG_FILES([Makefile
+ po/Makefile.in])
+AC_OUTPUT
+
+dnl ---------------------------------------------------------------------------
+dnl - Show summary
+dnl ---------------------------------------------------------------------------
+
+dnl The following 'for' block splits the CFLAGS variable into multiple lines of 4 options per line
+cflaglines=""
+cflagcount=0
+for flag in ${CFLAGS}; do
+ cflaglines=$cflaglines$flag" "
+ cflagcount=$(($cflagcount+1))
+ if (( $cflagcount % 4 == 0)); then
+ dnl Here we concatenate the current cflaglines variable with a newline and enough spaces
+ dnl such that the lines are correctly indented. Do not try to indent or reformat the
+ dnl position of the double quotes (\").
+ cflaglines=$cflaglines"
+ "
+ fi
+done;
+
+echo "
+ ${PACKAGE} $VERSION
+ `echo ${PACKAGE} $VERSION | sed "s/./=/g"`
+
+ prefix: ${prefix}
+ datarootdir: ${datarootdir}
+ datadir: ${datadir}
+ pkgdatadir: `if test x${pkgdatadir} != "x"; then echo ${pkgdatadir}; else echo ${datadir}/${PACKAGE}; fi`
+ source code location: ${srcdir}
+ compiler: ${CC}
+ cflags: ${cflaglines}
+ Maintainer mode: ${USE_MAINTAINER_MODE}
+ VTE: ${vte_package}
+ Use *_DISABLE_DEPRECATED: ${enable_deprecation_flags}
+"
diff --git a/system/tilda/tilda.1 b/system/tilda/tilda.1
deleted file mode 100644
index 784217ece6..0000000000
--- a/system/tilda/tilda.1
+++ /dev/null
@@ -1,95 +0,0 @@
-.TH "TILDA" "1" "June 2008" "tilda 0.09.6" "User Commands"
-.SH "NAME"
-tilda \- first person shooter console likeness terminal
-.SH "DESCRIPTION"
-\fBTilda\fR is a terminal emulator taking after the likeness of many classic
-terminals from first person shooter games, Quake, Doom and Half\-Life
-(to name a few), where the terminal has no border and is hidden from
-the desktop until a key is pressed.
-.SS "Usage:"
-.IP
-tilda [OPTION...]
-.SS "Help Options:"
-.TP
-\fB\-?\fR, \fB\-\-help\fR
-Show help options
-.TP
-\fB\-\-help\-all\fR
-Show all help options
-.TP
-\fB\-\-help\-gtk\fR
-Show GTK+ Options
-.SS "Application Options:"
-.TP
-\fB\-a\fR, \fB\-\-antialias\fR
-Use Antialiased Fonts
-.TP
-\fB\-b\fR, \fB\-\-background\-color\fR
-Set the background color
-.TP
-\fB\-c\fR, \fB\-\-command\fR
-Run a command at startup
-.TP
-\fB\-h\fR, \fB\-\-hidden\fR
-Start Tilda hidden
-.TP
-\fB\-f\fR, \fB\-\-font\fR
-Set the font to the following string
-.TP
-\fB\-l\fR, \fB\-\-lines\fR
-Scrollback Lines
-.TP
-\fB\-s\fR, \fB\-\-scrollbar\fR
-Use Scrollbar
-.TP
-\fB\-t\fR, \fB\-\-transparency\fR
-Opaqueness: 0\-100%
-.TP
-\fB\-v\fR, \fB\-\-version\fR
-Print the version, then exit
-.TP
-\fB\-w\fR, \fB\-\-working\-dir\fR
-Set Initial Working Directory
-.TP
-\fB\-x\fR, \fB\-\-x\-pos\fR
-X Position
-.TP
-\fB\-y\fR, \fB\-\-y\-pos\fR
-Y Position
-.TP
-\fB\-B\fR, \fB\-\-image\fR
-Set Background Image
-.TP
-\fB\-C\fR, \fB\-\-config\fR
-Show Configuration Wizard
-.TP
-\fB\-\-display\fR=\fIDISPLAY\fR
-X display to use
-.SH "COPYRIGHT"
-Copyright \(co 2005,2008 Tristan Sloughter (sloutri@iit.edu)
-.br
-Copyright \(co 2005,2008 Ira W. Snyder (tilda@irasnyder.com)
-.br
-Copyright \(co 2007,2008 Ken Dreyer (kdreyer@chicagolug.org)
-.PP
-This program comes with ABSOLUTELY NO WARRANTY.
-This is free software, and you are welcome to redistribute it
-under certain conditions. See the file COPYING for details.
-.SH "SEE ALSO"
-The full documentation for
-.B tilda
-is maintained as a Texinfo manual. If the
-.B info
-and
-.B tilda
-programs are properly installed at your site, the command
-.IP
-.B info tilda
-.PP
-should give you access to the complete manual.
-.SH "BUGS"
-Please report it using
-.B "reportbug tilda"
-.SH "AUTHOR"
-Davide Truffa <davide@catoblepa.org> wrote this manpage for
-inclusion on the Debian Project but it could be used for others.
diff --git a/system/tilda/tilda.SlackBuild b/system/tilda/tilda.SlackBuild
index 7b6dd9a340..8fb9f920bc 100644
--- a/system/tilda/tilda.SlackBuild
+++ b/system/tilda/tilda.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for tilda.
#
-# Copyright 2017-2022 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2017-2024 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
# Copyright 2009 Erik W. Hanson, Minneapolis, MN, USA
#
@@ -28,7 +28,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tilda
-VERSION=${VERSION:-1.5.4}
+VERSION=${VERSION:-2.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -71,6 +71,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cp -a $CWD/configure.ac $PRGNAM-$PRGNAM-$VERSION/
cd $PRGNAM-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -94,9 +95,6 @@ make install-strip DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/man/man1
-cp $CWD/tilda.1 $PKG/usr/man/man1
-
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
diff --git a/system/tilda/tilda.info b/system/tilda/tilda.info
index 140f4d4805..3e3a265c01 100644
--- a/system/tilda/tilda.info
+++ b/system/tilda/tilda.info
@@ -1,8 +1,8 @@
PRGNAM="tilda"
-VERSION="1.5.4"
+VERSION="2.0.0"
HOMEPAGE="https://github.com/lanoxx/tilda"
-DOWNLOAD="https://github.com/lanoxx/tilda/archive/tilda-1.5.4.tar.gz"
-MD5SUM="35ac6ced02e855714f9ae25cf0434505"
+DOWNLOAD="https://github.com/lanoxx/tilda/archive/tilda-2.0.0.tar.gz"
+MD5SUM="94b07981c67c300d719fb0bb557cd01e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="confuse"