summaryrefslogtreecommitdiffstats
path: root/system/wezterm/wezterm.SlackBuild
diff options
context:
space:
mode:
author Julian Grinblat2024-02-15 15:52:32 +0100
committer Willy Sudiarto Raharjo2024-02-15 17:23:27 +0100
commit19cab8b1b74923980353b5c2e82ea8c7a76f3c61 (patch)
tree310d073ed0c7c53613b0e07e9af1a04f9124340b /system/wezterm/wezterm.SlackBuild
parent7458524347e44f27c383649af5aeba8f8c4e3253 (diff)
downloadslackbuilds-19cab8b1b74923980353b5c2e82ea8c7a76f3c61.tar.gz
system/wezterm: Updated for version 20240203_110809_5046fc22
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/wezterm/wezterm.SlackBuild')
-rw-r--r--system/wezterm/wezterm.SlackBuild30
1 files changed, 7 insertions, 23 deletions
diff --git a/system/wezterm/wezterm.SlackBuild b/system/wezterm/wezterm.SlackBuild
index 0877084da7..ad337fa667 100644
--- a/system/wezterm/wezterm.SlackBuild
+++ b/system/wezterm/wezterm.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wezterm
-VERSION=${VERSION:-20230712_072601_f4abf8fd}
+VERSION=${VERSION:-20240203_110809_5046fc22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,36 +80,20 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-${VERSION//_/-}.tar.gz
mv $PRGNAM-${VERSION//_/-} $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
-tar xvf $CWD/harfbuzz-8.1.1.tar.gz -C deps/harfbuzz/harfbuzz --strip-components=1
+tar xvf $CWD/harfbuzz-8.3.0.tar.gz -C deps/harfbuzz/harfbuzz --strip-components=1
tar xvf $CWD/zlib-1.2.11.tar.gz -C deps/freetype/zlib --strip-components=1
tar xvf $CWD/libpng-8439534daa1d3a5705ba92e653eda9251246dd61.tar.gz -C deps/freetype/libpng --strip-components=1
tar xvf $CWD/freetype2-e4586d960f339cf75e2e0b34aee30a0ed8353c0d.tar.gz -C deps/freetype/freetype2 --strip-components=1
-mkdir image-fe06978
-tar xvf $CWD/image-fe069785ae245a2c510fd724ef96da283b05a236.tar.gz -C image-fe06978 --strip-components=1
-touch image-fe06978/.cargo-ok
-mkdir rust-xcb-41cc7e93ef1d12da
-tar xvf $CWD/rust-xcb-dbdaa01c178c6fbe68bd51b7ad44c08172181083.tar.gz -C rust-xcb-41cc7e93ef1d12da --strip-components=1
-touch rust-xcb-41cc7e93ef1d12da/.cargo-ok
-mkdir xcb-imdkit-rs-1f85ad932c246e33
-tar xvf $CWD/xcb-imdkit-rs-e59e4a6df065b702e0c22fa2dcea00bd8301a446.tar.gz -C xcb-imdkit-rs-1f85ad932c246e33 --strip-components=1
-touch xcb-imdkit-rs-1f85ad932c246e33/.cargo-ok
+mkdir xcb-imdkit-rs-215ce4b08ac9c482
+tar xvf $CWD/xcb-imdkit-rs-215ce4b08ac9c4822e541efd4f4ffb1062806051.tar.gz -C xcb-imdkit-rs-215ce4b08ac9c482 --strip-components=1
+touch xcb-imdkit-rs-215ce4b08ac9c482/.cargo-ok
-tar xvf $CWD/xcb-imdkit-30e2f16f9a8b0e338e25ce5e3643809a07ad41f0.tar.gz -C xcb-imdkit-rs-1f85ad932c246e33/deps/xcb-imdkit --strip-components=1
-
-sed -i '/xcb/d' Cargo.toml
+tar xvf $CWD/xcb-imdkit-30e2f16f9a8b0e338e25ce5e3643809a07ad41f0.tar.gz -C xcb-imdkit-rs-215ce4b08ac9c482/deps/xcb-imdkit --strip-components=1
cat << EOF >> Cargo.toml
-xcb = { path = "rust-xcb-41cc7e93ef1d12da" }
-
-[patch."https://github.com/rust-x-bindings/rust-xcb"]
-xcb = { path = "rust-xcb-41cc7e93ef1d12da" }
-
-[patch."https://github.com/image-rs/image"]
-image = { path = "image-fe06978" }
-
[patch."https://github.com/wez/xcb-imdkit-rs"]
-xcb-imdkit = { path = "xcb-imdkit-rs-1f85ad932c246e33" }
+xcb-imdkit = { path = "xcb-imdkit-rs-215ce4b08ac9c482" }
EOF
# build offline